Skip to main content

Update 14 hangs when closing windows

12 replies [Last post]
cowwoc
Offline
Joined: 2003-08-24
Points: 0

Hi,

When I run any Webstart, JavaFX or Applets in an stand-alone window and I click on the X button on the top right everything hangs. I can't even move the mouse pointer anymore. CPU usage is at zero.

I can break out of this hang by hitting ALT-TAB to take focus away from Java. I can then close the Window by right clicking on it in the task bar and choosing "close".

I am running Windows XP. Can anyone else reproduce this?

Gili

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jsm100
Offline
Joined: 2010-09-10
Points: 0

What is the status of this?

I still experience this with 6 update 20 on XP.

any known workarounds? same exact symptons as above.

rogyeu
Offline
Joined: 2006-07-30
Points: 0

I tried FF3 and IE 7. I cannot reproduce with 6u14-b01 on my XP SP3.

I tested with our applet demo (http://java.sun.com/applets/jdk/)

cowwoc
Offline
Joined: 2003-08-24
Points: 0

Did you try any Webstart or JavaFX applications? That's where I saw it most often...

Gili

rogyeu
Offline
Joined: 2006-07-30
Points: 0

Yes. I tried couple JavaFX and WebStart Apps and I don't see any issues.

On http://javafx.com/samples , I tried FishSim, FractalTree, Calculator, and ShoppingService
On http://java.sun.com/javase/technologies/desktop/javawebstart/demos.html, I tried SwingSet and Draw

I tried each with FF3 and IE 7 and I can't reproduce. Can you reproduce on more than 1 machine? Can you provide a specific sample for reproducing the issue?

cowwoc
Offline
Joined: 2003-08-24
Points: 0

> Yes. I tried couple JavaFX and WebStart Apps and I
> don't see any issues.
>
> On http://javafx.com/samples , I tried FishSim,
> FractalTree, Calculator, and ShoppingService
> On
> http://java.sun.com/javase/technologies/desktop/javawe
> bstart/demos.html, I tried SwingSet and Draw
>
> I tried each with FF3 and IE 7 and I can't reproduce.
> Can you reproduce on more than 1 machine? Can you
> provide a specific sample for reproducing the issue?

Odd. I just tried and I can't reproduce the problem on my home computer. When I get into work tomorrow morning I'll try reinstalling the JDK and testing again. Maybe the installation is corrupt somehow or there is something special about that computer...

Gili

linuxhippy
Offline
Joined: 2004-01-07
Points: 0

A stack-trace could be quite useful I guess when the hang occurs.
With jconsole such things can be done quite easily :)

cowwoc
Offline
Joined: 2003-08-24
Points: 0

FYI,

I can no longer reproduce this issue even on the original machine. The only thing that changed is that I've rebooted the machine in the past couple of days. Maybe it got into a bad state somehow. Anyway, please consider this issue resolved.

Thank you,
Gili

houtman
Offline
Joined: 2008-10-29
Points: 0

Hi,
um running an app with webstart;
http://www.infonode.net/index.html?idwdemo
java console says:
Java Web Start 1.6.0_12
Using JRE version 1.6.0_12 Java HotSpot(TM) Client VM
i've seen this hanging happen often.

it happens with windows which show the little yellow sign at the right top side of
the floating window, saying ("java application window")

when closing the window(either by alt-f4, or by app itself) the mouse hangs, there doesn't seem to be any CPU consumption, and as soon as alt-tab is pressed the app continues.
strange thing that sometimes it hangs, some time it doesn't..

mouse hangs, and alt-tab gets things running again, so i m not able to dump the thread stack from the Java Console..

WOW?! when i run "sysinternals process explorer" with an update of 5 sec. as soon as "pe" refreshes, my java app responds/continues ?!

anthony_p
Offline
Joined: 2006-07-24
Points: 0

Hi houtman,

Are you absolutely sure this problem affects unsigned Java applications only (those displaying the security warning with the top-level windows) and is not reproducible with signed applications at all? Is it possible to reproduce the issue when running from the command line (and possibly using the "-Djava.security.manager" option to turn the application into the untrusted mode)?

Can you please provide any short test case with the source code that can be used to reproduce that? Also please provide more details regarding the configuration of your software (OS version, installed service packs, etc.). Did you try 6u14, btw? What about older releases - is that reproducible with, say, 6u10?

--
best regards,
Anthony

ghaneman
Offline
Joined: 2006-11-09
Points: 0

I've noticed the same problem. I can't say for sure when the bug was introduced but it was around the time 6u10 came out. If I run any of the unsigned webstart demos on Sun's tutorial, then clicking the windows close, minimize or maximize buttons freezes the OS for about 5 secs. If the app has a JButton in it that closes the window, then that's ok. So it seems to have something to do with that little warning icon outside of the window and the window title buttons. Problem still occurs with 6u14.

Now I'm running a plain vanilla XP (latest SP and updates), nothing special about it, no fancy windows theme or window blinds etc. It has a relatively old (by today's standards) nvidia 6800GS graphics card. That's it. I tried reproducing the problem on another notebook running Vista but no luck. It was fine.

anthony_p
Offline
Joined: 2006-07-24
Points: 0

Hi ghaneman,

I filed the following CR to track this issue:

6851571 Soft system hang occurs when closing a top-level window with a security warning

It must become available on the bugs.sun.com site in a day or two. We'll try to investigate the bug. Thanks for your experiments.

--
best regards,
Anthony

yanguyen
Offline
Joined: 2009-07-12
Points: 0

I filed a bug report on this problem (Incident Review ID: 1476084) in March 2009, but did not follow up further.

I'd like to add the following observations.

1. The problem happens only on release 12 until current release. Release 11 and early have no problem.

2. The problem consistently happens when running the applet in a browser or from appletviewer command line. Strange enough, the same applet on the same computer running from within Eclipse (with jsdk release 12) does not show any problem.

3. The problem happens on a fresh installation of WinXP with no other application. In my case, I wiped out an Optiplex 745, installed XP with service pack 2, upgraded to service pack 3, then installed java release 13.

Here is my test applet

---------- BEGIN SOURCE ----------
=== file AppletFrame.java ===

import java.applet.*;
import java.awt.*;
import java.awt.event.*;

public class AppletFrame extends Applet implements ActionListener {
Button b;
public void init() {
setLayout(new BorderLayout());
b = new Button("Show Frame!");
add(b, "Center");

b.addActionListener(this);
}

public void actionPerformed(ActionEvent e) {
final Frame f = new Frame("Test Frame");
f.setBounds(200, 200, 300, 400);
f.setVisible(true);
f.add(new Label("Click on X at top right corner to close"));

f.addWindowListener(new WindowAdapter(){
public void windowClosing(WindowEvent we){
f.dispose();
}
});
}
}

=== File AppletFrame.html ===


---------- END SOURCE ----------