Skip to main content

Upgrade from JSF 1.1 to JSF 1.2 failed

1 reply [Last post]
ogi_prayogo
Offline
Joined: 2008-09-15
Points: 0

Dear all,

I tried to upgrade from JSF 1.1 to JSF 1.2 but failed. My environment is as follows.
JDK 1.5
Tomcat 6.0
Facelet
JSF Mojarra 1.2

The error is as follows, occurs when starting tomcat (my application is in context /web)

INFO: Initializing Sun's JavaServer Faces implementation (1.2_01-b04-FCS) for context '/web'
Feb 12, 2009 10:39:40 AM com.sun.faces.config.ConfigureListener contextInitialized
INFO: Completed initializing Sun's JavaServer Faces implementation (1.2_01-b04-FCS) for context '/web'
Feb 12, 2009 10:39:40 AM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Feb 12, 2009 10:39:40 AM org.apache.catalina.core.StandardContext start
SEVERE: Context [/web] startup failed due to previous errors

What I have included in WEB-INF/lib are:
JSTL 1.2 (standard.jar and jstl.jar)
JSF mojarra 1.2 (jsf-api.jar and jsf-impl.jar)
Facelets( el-api.jar, el-impl.jar, and jsf-facelet.jar)
commons-digester.jar
commons-beanutils.jar
commons-logging.jar
commons-collection.jar

Documentation that I read from mojarra FAQ states that i need EL, but that is included in Facelets.

Am i missing something? This application works OK in JSF 1.1, both using myfaces or RI.

the following is the part of web.xml that i used, maybe useful to locate what i am missing.

javax.faces.DEFAULT_SUFFIX
.xhtml

facelets.DEVELOPMENT
true

com.sun.faces.validateXml
true

com.sun.faces.verifyObjects
true

com.sun.faces.injectionProvider
com.sun.faces.vendor.GlassFishInjectionProvider

faces
javax.faces.webapp.FacesServlet
0

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Ryan Lubke

You need to use the latest JSF 1.2, as the version you're using is
several years old.
The latest version is 1.2_12.

After upgrading, make sure you remove the content under TOMCAT_HOME/work
*before* you restart the server.

If you're still having listener start issues after upgrading, you should
check the
other tomcat logs for the cause of the failure, as the console output is
very
helpful.

webtier@javadesktop.org wrote:
> Dear all,
>
> I tried to upgrade from JSF 1.1 to JSF 1.2 but failed. My environment is as follows.
> JDK 1.5
> Tomcat 6.0
> Facelet
> JSF Mojarra 1.2
>
> The error is as follows, occurs when starting tomcat (my application is in context /web)
>
> INFO: Initializing Sun's JavaServer Faces implementation (1.2_01-b04-FCS) for context '/web'
> Feb 12, 2009 10:39:40 AM com.sun.faces.config.ConfigureListener contextInitialized
> INFO: Completed initializing Sun's JavaServer Faces implementation (1.2_01-b04-FCS) for context '/web'
> Feb 12, 2009 10:39:40 AM org.apache.catalina.core.StandardContext start
> SEVERE: Error listenerStart
> Feb 12, 2009 10:39:40 AM org.apache.catalina.core.StandardContext start
> SEVERE: Context [/web] startup failed due to previous errors
>
> What I have included in WEB-INF/lib are:
> JSTL 1.2 (standard.jar and jstl.jar)
> JSF mojarra 1.2 (jsf-api.jar and jsf-impl.jar)
> Facelets( el-api.jar, el-impl.jar, and jsf-facelet.jar)
> commons-digester.jar
> commons-beanutils.jar
> commons-logging.jar
> commons-collection.jar
>
> Documentation that I read from mojarra FAQ states that i need EL, but that is included in Facelets.
>
> Am i missing something? This application works OK in JSF 1.1, both using myfaces or RI.
> [Message sent by forum member 'ogi_prayogo' (ogi_prayogo)]
>
> http://forums.java.net/jive/thread.jspa?messageID=331422
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: webtier-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: webtier-help@glassfish.dev.java.net