Skip to main content

jruby -S glassfish_rails helloV3 error

1 reply [Last post]
babyboss
Offline
Joined: 2009-02-04

I input "jruby -S glassfish_rails helloV3"
The doc here(http://docs.sun.com/app/docs/doc/820-4926/chapterone?a=view) told me that I am supposed to have "INFO: Rails instance instantiation took : 37754ms" output, however, I didn't get that output. Instead I hang in this output "INFO: GlassFish v3 startup time: Static(2759ms) startup servces(595ms) total(3354ms). Then I can't input any more command. I can stop it with control+C.

The document also said, run "http://localhost:3000/home/index" in my internet browser, and I should see, "Welcome to JRuby on Rails on the Sun GlassFish Enterprise Server!" message. However, I didn't, Instead, i see "HTTP Status 404
type Status report
message
description Not Found"
message, I did follow the instruction exactly.
"Deploying a Rails Application as a Directory" step works fine for me.

Thank you very much

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Vivek Pandey

webtier@javadesktop.org wrote:
> I input "jruby -S glassfish_rails helloV3"
> The doc here(http://docs.sun.com/app/docs/doc/820-4926/chapterone?a=view) told me that I am supposed to have "INFO: Rails instance instantiation took : 37754ms" output, however, I didn't get that output. Instead I hang in this output "INFO: GlassFish v3 startup time: Static(2759ms) startup servces(595ms) total(3354ms). Then I can't input any more command. I can stop it with control+C.
>
>
The docs were written and tested with GlassFish v3 prelude server and
the corrsponding glassfish gem release. The above message is to give
the idea that the server has started. The reason you see a different
output message is because the latest glassfish gem is based on b34
promotion of glasfish kernel and the status message has changed.

GlassFish gem is different from GlassFish v3 enterprise server,
basically it is meant to be run as single instance and hance the need to
do Ctrl+C. There is bug/rfe [1] reported to have Daemon feature with
glassfish gem and it is being worked on.
> The document also said, run "http://localhost:3000/home/index" in my internet browser, and I should see, "Welcome to JRuby on Rails on the Sun GlassFish Enterprise Server!" message. However, I didn't, Instead, i see "HTTP Status 404
> type Status report
> message
> description Not Found"
> message, I did follow the instruction exactly.
> "Deploying a Rails Application as a Directory" step works fine for me.
>
>
I think this is documentation bug. It is supposed to be:

http://localhost:3000/index

Can you try it and see if it works for you?

-vivek.

[1]http://rubyforge.org/tracker/index.php?func=detail&aid=23723&group_id=5450&atid=21080
> Thank you very much
> [Message sent by forum member 'babyboss' (babyboss)]
>
> http://forums.java.net/jive/thread.jspa?messageID=330422
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: webtier-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: webtier-help@glassfish.dev.java.net