Skip to main content

Jruby, rails require higher RubyGem version, but I can't do anything

2 replies [Last post]
babyboss
Offline
Joined: 2009-02-04
Points: 0

Hello:
I did 'Jruby script/generate controller home index', and I got "Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please 'gem update --system' and try again" message. I follwed, and did 'gem update --system', but it tells me there is nothing to update. My rails version is 2.2.2, I tried to install lower version, but did 'gem query --remote --name-matches rails', only rails 2.2.2 version comes up, which is the one I am having. Thank you very much.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Jacob Kessler

This is a known issue updating from RubyGems 1.2.0 to 1.3.1. See
http://rubyforge.org/forum/forum.php?forum_id=28071 for details. The
solution (listed on that page) is to run

gem install rubygems-update

followed by

update_rubygems

Both of those commands may need to be run as an admin user.

webtier@javadesktop.org wrote:
> Hello:
> I did 'Jruby script/generate controller home index', and I got "Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please 'gem update --system' and try again" message. I follwed, and did 'gem update --system', but it tells me there is nothing to update. My rails version is 2.2.2, I tried to install lower version, but did 'gem query --remote --name-matches rails', only rails 2.2.2 version comes up, which is the one I am having. Thank you very much.
> [Message sent by forum member 'babyboss' (babyboss)]
>
> http://forums.java.net/jive/thread.jspa?messageID=330168
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: webtier-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: webtier-help@glassfish.dev.java.net

Vivek Pandey

Which version of jruby you are using? jruby -v will tell you what
version it is.

Just form your description it looks you need later version of jruby, try
1.1.6. RubyGems is not a gem that you can install using a gem install as
such. It ships as part of jruby distro (lib/ruby/site_ruby/1.8/rubygems).

You can also try to post message to user@jruby.codehaus.org.

-vivek.
webtier@javadesktop.org wrote:
> Hello:
> I did 'Jruby script/generate controller home index', and I got "Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please 'gem update --system' and try again" message. I follwed, and did 'gem update --system', but it tells me there is nothing to update. My rails version is 2.2.2, I tried to install lower version, but did 'gem query --remote --name-matches rails', only rails 2.2.2 version comes up, which is the one I am having. Thank you very much.
> [Message sent by forum member 'babyboss' (babyboss)]
>
> http://forums.java.net/jive/thread.jspa?messageID=330168
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
> For additional commands, e-mail: webtier-help@glassfish.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: webtier-unsubscribe@glassfish.dev.java.net
For additional commands, e-mail: webtier-help@glassfish.dev.java.net