Skip to main content

Can't get Eclipse/GlassFish plugin to work - missing eclipse component

1 reply [Last post]
peterjford
Offline
Joined: 2008-12-15
Points: 0

I installed the GlassFish plugin as described on the Metro guide (https://metro.dev.java.net/guide/Developing_with_Eclipse.html) but it doesn't show up when I use new->Server; when I checked the configuration I found this message:

GlassFish Java EE 5 Server (1.0.17) requires plug-in "org.eclipse.debug.ui (3.4.0)", or later version.

However the Eclipse update manager doesn't have smarts enough to go and get this missing plugin and I can't get the thing to locate it on any of the update sites I have (and in fact that package name suggests this is actually an Eclipse component, so I have no idea why it's not finding it).

Does anyone know which site I should tell the update manager to search for this debug plugin?

BTW: using eclipse Europa (3.3.2), GlassFish plugin 1.0.17.

Added my version info

Message was edited by: peterjford

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jmordax
Offline
Joined: 2008-03-18
Points: 0

From the error it seems GlassFish Plug-in 1.0.17 requires Eclipse R3.4.x (aka Ganymedes) instead R3.3.x (aka Europa). Just wondering here (I haven't search into release notes to check if R3.3.x is not supported anymore)... but if that is the case, it is not as easy as upgrade also that org.eclipse.debug.ui, you should migrate completely to new version of Eclipse.

Regards,

Chemi.