Skip to main content

Preverify error

3 replies [Last post]
dlindberg
Offline
Joined: 2008-12-18

I just installed WTK2.5.2_01 and tried to package my Midlet in eclipse. I now get the following error:

Error preverifying class com.sun.amms.control.camera.CameraCtrl - AppName - Unknown - Java Problem

Any ideas why? If this is the wrong place to post this, please let me know.
Thanks in advance,
Dan'l

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
sfitzjava
Offline
Joined: 2003-06-15

This is about the best place for your question that I can think of. :)

Need a little more info however. What OS are you on? Win/Lin/Mac?
Did you install the eclipse ME plugin (formerly EclipseME, now the the MTJ project)
If you did get the ME plugin did you setup the javaME preferences?
And then finally did you configure the project to have support for the MMAPI JSR,
and possibly the AMS API. Also you may need to verify you have all the Jars
listed in the build path for the project.

-Shawn

dlindberg
Offline
Joined: 2008-12-18

Thanks for the quick reply.
I'm using the latest version of Eclipse in a Windows Vista environment. I did install the MTJ plugin and configured the JaveME preferences. All of the jars listed in the build path are in the locations specified by the build path. I don't recall seeing anything about MMAPI JSR or AMS API. I'll look into that.

Thanks again,
Dan'l

jaywayjohan
Offline
Joined: 2008-06-18

I think that this i problem in the MTJ plug-in. Sometimes this is fixed if you create a new project. It worked for me at least. Or you could use NetBeans...