Skip to main content

Netbeans ubuntu x11 error

1 reply [Last post]
ostense
Offline
Joined: 2005-03-23
Points: 0

Hi !

I have Ubuntu Hardy. Up to now I have been using a beta version of Netbeans 6.5 and it worked . I thought I should upgrade to the official 6.5 release. The installation went fine, but it is impossible to start netbeans. Netbeans starts , but abends after loading modules. Some of the messages I got is :

"
# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb403495d, pid=27075, tid=2986847120
#
# Java VM: Java HotSpot(TM) Client VM (11.0-b16 mixed mode, sharing linux-x86)
# Problematic frame:
# C [libX11.so.6+0x3f95d] _XRead+0x2d
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid27075.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

"

I have tried to go back , reinstall X11 , other JDK's , but nothing helps. It abends with the same message. The only other thing I have done with my ubuntu is to install NX server. All other applications, both java and native function as normal. Has anybody a good tip?

Thank You!

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ostense
Offline
Joined: 2005-03-23
Points: 0

Well I resolved it. It seems like Netbeans 6.5 , Ubuntu Hardy and NX server and client gets a X11 dump. I removed all server and client NX and the NX compression lib for X11 and then Netbeans works.