Skip to main content

Which Servlet spec?

4 replies [Last post]
peterjford
Offline
Joined: 2008-12-15

I'm using GlassFish v2ur2 - can someone tell me which version of the Servlet API spec is supported? I've been assuming 2.5 but I'm having problems that make it look like that's not the one.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
peterjford
Offline
Joined: 2008-12-15

The original web.xml included a DOCTYPE tag referencing the 2.3 schema. I removed that and specified - the app is now deploying without the error message. Thanks!

areplogle
Offline
Joined: 2007-02-07

I know I've done that more than once ;)

Glad to hear it's working :)

Andrew

areplogle
Offline
Joined: 2007-02-07

v2 is JEE 5, so servlet spec 2.5 is correct.

What is the problem?

peterjford
Offline
Joined: 2008-12-15

I'm getting a message during application deployment saying there's something wrong with my "metadata-complete" attribute on the web-app element. However I think there are other things wrong with the web.xml (this app was modified from a 2.3-compliant app). I'm working on it and I should know very soon if this is correct.