Skip to main content

Java7 RPMs conflict with Java6 RPMs

2 replies [Last post]
donv
Offline
Joined: 2008-12-04
Points: 0

Hi all!

I have multiple version of Java5 and Java6 installed using the RPMs from Sun, but when trying to install an RPMs for Java7 I get the following error message:

file /etc/init.d/jexec from install of jdk-2000:1.7.0-ea.i586 conflicts with file from package jdk-2000:1.6.0_07-fcs.i586
file /etc/init.d/jexec from install of jdk-2000:1.7.0-ea.i586 conflicts with file from package jdk-2000:1.6.0_11-fcs.i586

Why can I not install Java7 and Java6 in parallel?

Any answer is greatly appreciated.

Uwe Kubosch
Norway

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
asailer
Offline
Joined: 2006-11-09
Points: 0

Same for me. Here's the solution that worked for me:

The jdk-1.7*.rpm.bin file extracts an rpm file, and then I get that error. I manually installed the rpm:

rpm -i --force jdk-1.7*.rpm

Message was edited by: asailer

donv
Offline
Joined: 2008-12-04
Points: 0

Well, two months have passed since I posted my question. Is this "feedback forum" not attended by anyone in the project, or is my question to difficult to answer?

Why are OpenJDK7 RPMs conflicting with JDK6 RPMs, and how can I fix or avoid the problem?