Skip to main content

Regarding EJB3.0 support in glassfish-v3prelude

1 reply [Last post]
Anonymous

Hi,

I am getting error when I am trying to add EJB3.0 project to
glassfish-v3prelude runtime. The error message is

"The server does not support version 5.0 of the J2EE Enterprise
application specification".

Below is the snapshot of error message.

Please let us know whether glassfish-v3prelude supports EJB3.0 or not?

Also from below glassfish site we read that glassfish-v3 prelude does
not supports EJB3.0.

https://glassfish.dev.java.net/public/comparing_v2_and_v3.html#4

Thanks & Regards

sravanthi

This e-mail and any files transmitted with it are for the sole use of

the intended recipient(s) and may contain confidential and privileged

information.
If you are not the intended recipient, please contact the sender by

reply e-mail and destroy all copies of the original message.
Any unauthorized review, use, disclosure, dissemination, forwarding,

printing or copying of this email or any action taken in reliance on this

e-mail is strictly prohibited and may be unlawful.

[att1.html]
[image001.png]

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ksak
Offline
Joined: 2005-05-20

No, GlassFish v3 Prelude does not include a full EJB 3.0 implementation. You can download
a partial pre-release implementation of some EJB 3.1 features from the update center but the bulk of EJB 3.0(e.g. ejb-jar / .ear support) is not available on v3. If you need a full Java EE 5 implementation right now then Glassfish v2 is your best bet.