Skip to main content

Unable to debug MIDlet on WM6 real device

No replies
jrad11
Offline
Joined: 2008-11-03
Points: 0

Hello,

I am new to J2ME and am trying to debug a simple app that I wrote.

Using NetBeans 6.1, I was able to deploy the app I created using ActiveSync.
I then used File Explorer on the device to run the app, which ran successfully.

I want to be able to debug the same app using NetBeans.
When I try to debug, I get the following output:

pre-init:
pre-load-properties:
exists.config.active:
exists.netbeans.user:
exists.user.properties.file:
load-properties:
exists.platform.active:
exists.platform.configuration:
exists.platform.profile:
basic-init:
cldc-pre-init:
cldc-init:
cdc-init:
ricoh-pre-init:
ricoh-init:
semc-pre-init:
semc-init:
savaje-pre-init:
savaje-init:
nokiaS80-pre-init:
nokiaS80-init:
nsicom-pre-init:
nsicom-init:
post-init:
init:
conditional-clean-init:
conditional-clean:
clean:
pre-clean:
clean-timestamp:
Deleting: C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\.timestamp
clean-preprocessed:
Deleting directory C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preprocessed
clean-classes:
Deleting directory C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\compiled
clean-obfuscated:
clean-preverified:
Deleting directory C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preverifysrc
Deleting directory C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preverified
clean-manifest:
Deleting: C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\manifest.mf
clean-jar:
Deleting: C:\JR_SWDev\J2ME\PIMSeedMIDlet\dist\PIMSeedMIDlet.jar
clean-jad:
Deleting: C:\JR_SWDev\J2ME\PIMSeedMIDlet\dist\PIMSeedMIDlet.jad
clean-javadoc:
clean-j9:
clean-ricoh:
clean-semc:
clean-savaje:
post-clean:
do-clean:
deps-jar:
pre-preprocess:
do-preprocess:
Created dir: C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preprocessed
Pre-processing 1 file(s) into C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preprocessed directory.
post-preprocess:
preprocess:
pre-compile:
extract-libs:
Created dir: C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\compiled
do-compile:
Compiling 1 source file to C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\compiled
post-compile:
compile:
pre-obfuscate:
proguard-init:
skip-obfuscation:
proguard:
post-obfuscate:
obfuscate:
pre-preverify:
do-preverify:
Created dir: C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preverifysrc
Copying 1 file to C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preverifysrc
Created dir: C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preverified
Preverifying 1 file(s) into C:\JR_SWDev\J2ME\PIMSeedMIDlet\build\preverified directory.
post-preverify:
preverify:
pre-jar:
set-password-init:
set-keystore-password:
set-alias-password:
set-password:
create-jad:
add-configuration:
add-profile:
do-extra-libs:
nokiaS80-prepare-j9:
nokiaS80-prepare-manifest:
nokiaS80-prepare-manifest-no-icon:
nokiaS80-create-manifest:
semc-build-j9:
do-jar:
Building jar: C:\JR_SWDev\J2ME\PIMSeedMIDlet\dist\PIMSeedMIDlet.jar
nsicom-create-manifest:
do-jar-no-manifest:
update-jad:
Updating application descriptor: C:\JR_SWDev\J2ME\PIMSeedMIDlet\dist\PIMSeedMIDlet.jad
Generated "C:\JR_SWDev\J2ME\PIMSeedMIDlet\dist\PIMSeedMIDlet.jar" is 2805 bytes.
ricoh-init-dalp:
ricoh-add-app-icon:
ricoh-build-dalp-with-icon:
ricoh-build-dalp-without-icon:
ricoh-build-dalp:
savaje-prepare-icon:
savaje-build-jnlp:
post-jar:
jar:
remove-timestamp:
pre-debug:
cldc-debug:
Copying 1 file to C:\JR_SWDev\J2ME\PIMSeedMIDlet\dist\nbrun23818
Copying 1 file to C:\JR_SWDev\J2ME\PIMSeedMIDlet\dist\nbrun23818
Jad URL for OTA execution: http://localhost:8082/servlet/org.netbeans.modules.mobility.project.jam....
Starting emulator in debug server mode on port 3561
Cannot create device connection: Failed to connect to device 11!
nbdebug:
KdpDebugTask connecting to debugger 1 ..
KdpDebugTask connecting to debugger 2 ..
KdpDebugTask connecting to debugger 3 ..
KdpDebugTask connecting to debugger 4 ..
KdpDebugTask connecting to debugger 5 ..
KdpDebugTask connecting to debugger 6 ..
Connecting JPDA Debugger to emulator timed out after 6 attempts and 38 seconds.
C:\JR_SWDev\J2ME\PIMSeedMIDlet\nbproject\build-impl.xml:916: The following error occurred while executing this line:
C:\JR_SWDev\J2ME\PIMSeedMIDlet\nbproject\build-impl.xml:1007: Connecting JPDA Debugger to emulator timed out after 6 attempts and 38 seconds.
BUILD FAILED (total time: 49 seconds)

If there is any more information I can give, please let me know.
Thanks in advance.

JR