Skip to main content

How to get new java plugin to work in Ubuntu

1 reply [Last post]
dug
Offline
Joined: 2003-06-11

I'm using Ubuntu Intrepid, which has java 6 update 10 b33 installed, but the old plugin is still used.
I used update-alternatives to install and configure the newer libnpjp2.so plugin and remove the old libjavaplugin.so from /usr/lib/firefox/plugins and /usr/lib/mozilla/plugins, but new applets don't work, for example these:
https://scenegraph-demos.dev.java.net/demo-applets.html

I downloaded and extracted the latest 6u10b33 from the sun site and pointed to those, too, and still it didn't work.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
dug
Offline
Joined: 2003-06-11

I think I found the solution. I ran these commands in terminal:

sudo update-alternatives --install /etc/alternatives/xulrunner-1.9-javaplugin.so xulrunner-1.9-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so 50

sudo update-alternatives --config xulrunner-1.9-javaplugin.so

and select the libnpjp2.so option (2)

I posted that info here: http://edtechdev.blogspot.com/2008/10/getting-new-java-6-update-10-plugi...

and I posted a request to have the new plugin enabled by default in Ubuntu instead of the old one:
https://bugs.launchpad.net/ubuntu/+bug/291135