Skip to main content

Sun Wireless Toolkit Client (SJWC) 2.0.1.0.07 and phoneME Feature

5 replies [Last post]
Anonymous

Hi,
I have got a new HP Ipaq 914, nowadays it also includes Sun Wireless
Toolkit Client (SJWC) 2.0.1.0.07.

I have understand that SJWC is phoneME Feature + SUN have added
optimizations and commercial value-added components , such as optional
JSRs, platform tuned optimizations, etc.

But what version of phoneME Feature is SJWC 2.0.1.0.07 based on?
Which JSRs are supported by the implementation on SJWC 2.0.1.0.07?
Is SJWC 2.0.1.0.07 supported in Netbeans 6.5?

I have try to find information about this, on http://java.sun.com/javame/overview/products.jsp#cldc
they talk about Sun Java Wireless Client version 1.1.3 and upcoming
version Sun Java Wireless Client version 1.1.4, but nothing about Sun
Wireless Toolkit Client 2.0.1.0.07?

Regards,
Ove

---------------------------------------------------------------------
To unsubscribe, e-mail: feature-unsubscribe@phoneme.dev.java.net
For additional commands, e-mail: feature-help@phoneme.dev.java.net

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
akz003
Offline
Joined: 2006-10-13
Points: 0

Hi, Ove

thanks for the interest.
Just wanted to comment on few things.

SJWC is Sun Java Wireless Client which is Sun commercial product used as a basis for phoneME Feature open source project.

There are different Sun product called Sun Java Wireless ToolKit - which is well known as WTK - the desktop toolkit for the Mobile Java application developers. The new version is being released now and available in Early Access version with the new name Java ME SDK.
http://java.sun.com/javame/downloads/sdk30ea.jsp

You are right about SJWC - it is phoneME Feature +.
The first release of phoneME Feature MR1 was based on SJWC 1.1.3
The second release of phoneME Feature MR2 was aligned with SJWC 2.0
The docs for 2.0 could be found here:
http://java.sun.com/javame/reference/docs/sjwc-2.0-web/
So you could probably compare it with MR2:
https://phoneme.dev.java.net/content/phoneme_feature_r2.html

Unfortunately, I can not comment on new HP device, as I just do not have an information what 2.0.1.0.07 version means there. I can think that it is aligned with base SJWC 2.0 version.

What kind of Netbeans support are you looking for?
phoneME Feature MR3 which is aligned with SJWC 2.1 is also aligned with WTK 2.5.2 in a way that you could use WTK as an emulator for SJWC runtime. And as WTK goes to the Netbeans as an Neatbeans Mobility Pack - you could theoretically have SJWC runtime in Netbeans through WTK/NB Mobility Pack.

phoneME Feature MR4 on which we are currently working on is aligned with SJWC 2.2 which is an official runtime for JavaME SDK (former WTK) which would go to Netbeans Mobility Pack.
So the goal is to reduce the fragmentation having the very consistent behavior in between Open Source and Sun based products: development tools and java runtimes on real devices.

Regards
Kostya

ovjo122
Offline
Joined: 2005-06-27
Points: 0

Hi Kostya,
Thanks very much, I have understand this:
- SJWC 2.2 is based on phoneME Feature MR4, SJWC 2.2 which is an official runtime for JavaME SDK 3.0.
- SJWC 2.1 is based on phoneME Feature MR3 , SJWC 2.1 is also aligned with WTK 2.5.2

I suppose I then will be able to upgrade my HP Ipaq 914 from SJWC 2.0.1.0.07 to SJWC 2.2?
(because WinMobile CAB for device is bundled with Java ME Platform SDK. You can find WinMobile CAB file in \on-device\winmobile-arm).

Which JSRs are supported by the implementation on SJWC 2.2?
Is it MSA 1.0, 1.1 or 2.0?

Netbeans 6.5 will soon be released (in November 2008), will it include JavaME SDK 3.0 or WTK 2.5.2?

Regards,
Ove Nordström

akz003
Offline
Joined: 2006-10-13
Points: 0

Hi, Ove

Not sure that I have an info RE Netbeans, sorry.
SJWC 2.2/phoneME Feature MR4 will be MSA 1.1 ready + JSR239,JSR256,JSR280
Unfortunately we have legal restrictions to share some JSRs like 184 in OpenSource.

I am sure that smb needs to port 2.2 to wince first so you would be able to get the Mobile Java platform updated on your device - as I know there are Davy in this forum, one of the phoneME Feature contributors who has his own port of phoneME Feature to wince.

Regards
Kostya

hnipak
Offline
Joined: 2006-02-03
Points: 0

Can the runtime included WTK 3.0 EA be used for on-device debugging only? I've found no way to install/run a midlet in it... Thank you.

tbrandalik
Offline
Joined: 2005-05-12
Points: 0

WinCE binary shipped with Java ME SDK 3.0 EA is for evaluation and testing only. It means that users can deploy midlets only when connected to SDK but not from filesystem or web.

Thanks for your interest
-Tomas