Skip to main content

Thinlet in phoneme advanced in Windows Mobile?

5 replies [Last post]
jedusan
Offline
Joined: 2008-10-15
Points: 0

Hello all!

I had some problems with making Thinlet v0.43 (www.thinlet.com) work in phoneme advanced in Windows Mobile.

Someone succeeded?

How should I proceed?

What should I do?

Thanks
José Eduardo

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
miriam.rojas
Offline
Joined: 2011-03-18
Points: 0

Hi José Eduardo, Davy and everybody! I know that the topic is a little bit old (sorry about that) but i really hope that some of you can help me. I'm wondering if the problem that you had is similar to mine. The only problem that i'm having it's that even though the display of the forms is ok in my phone i can't write in textfields/textareas and also i can't select options in combobox; i mean i can't do anything :( I've tried with all the old versions of thinlet and i haven't had any result, can you help me pleaaaaase? What kind of problems did you have? And which version of thinlet did you use? And which generics in the source code of thinlet are not compatible with JDK 1.4?
Thanks in advance!
Miriam.

jedusan
Offline
Joined: 2008-10-15
Points: 0

I received success in doing the Thinlet - older version(http://thinlet.sourceforge.net/home.html) work in phoneme advanced in Windows Mobile.
But with a bad performance, very slowly.
What must I do?
Thanks

jedusan
Offline
Joined: 2008-10-15
Points: 0

Doubt on the performance of Thinlet - older version (http://thinlet.sourceforge.net/home.html) in phoneME Advanced on Windows Mobile.

davyp
Offline
Joined: 2007-01-03
Points: 0

I don't think Thinlet v0.43 will work out of the box. I see generics in the source code and those
are not compatible with JDK 1.4. The precompiled jars are made with JDK 1.5 (or higher), but
class files with major.minor version 49.0 are unsupported on J2ME Personal Profile 1.1.
You will have to rewrite Thinlet v0.43 so that you can compile everything with javac -source
1.4 -target 1.4 ... and make sure you do not use any APIs that do not exist in J2ME PP.

Davy

jedusan
Offline
Joined: 2008-10-15
Points: 0

Thanks davyp.
I will do that. After I will post the results back here.

José Eduardo