Skip to main content

Warning: ignoring port "AshHlcMemMntcSOAP": no SOAP address specified

2 replies [Last post]
garberfc
Offline
Joined: 2008-10-10

I'm running wsimport from the Sun 1.6 jdk. I'm getting the following message and I don't know why.

Can anyone make some suggestions?

Thanks in advance,

F

[WARNING] ignoring port "AshHlcMemMntcSOAP": no SOAP address specified. try running wsimport with -extension switch.
line 181 of file:/C:/users/xxx/ATV/AshHlc-WS/10-10%20Jax-WS%20Working/AshHlcMemMntc.wsdl

[WARNING] Service "AshHlcMemMntc" does not contain any usable ports. try running wsimport with -extension switch.
line 178 of file:/C:/users/xxx/ATV/AshHlc-WS/10-10%20Jax-WS%20Working/AshHlcMemMntc.wsdl

Portion of file. First line is number 178:

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
garberfc
Offline
Joined: 2008-10-10

I was able to solve my problem! I had a bad URL in my namespace definitions and that was messing everything up. I with the error message was more informative...

Bad: xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap"
Good: xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"

Note the missing last slash. That was all...

F

garberfc
Offline
Joined: 2008-10-10

I was able to solve my problem! I had a bad URL in my namespace definitions and that was messing everything up. I with the error message was more informative...

Bad: xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap"
Good: xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"

Note the missing last slash. That was all...

F