Skip to main content

Windows Mobile

5 replies [Last post]
Anonymous

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Renato Fagalde

hi everybody!

I have a ready application that runs on Symbian 6, I'm using the
JSR172, to handle communication via the Web (also use the lwuit). Now that
this application can not run on Windows Mobile.

How can I do to make the application works on Windows Mobile?

Thank you
Fagalde
[att1.html]

Hinkmond Wong

Renato Fagalde wrote:
> hi everybody!
>
>
> I have a ready application that runs on Symbian 6, I'm using
> the JSR172, to handle communication via the Web (also use the lwuit).
> Now that this application can not run on Windows Mobile.
>
> How can I do to make the application works on Windows Mobile?

Hi Fagalde,

What type of error do you see? What is the exact output message and
incorrect behavior when you say it "cannot run"?

Hinkmond

---------------------------------------------------------------------
To unsubscribe, e-mail: advanced-unsubscribe@phoneme.dev.java.net
For additional commands, e-mail: advanced-help@phoneme.dev.java.net

Renato Fagalde

Hello!

The problem is when you open a class that will handle the connection to
the Web Services(stubs), then won the exception
java.lang.NoClassDefFoundError

how do I turn the specification jsr172 in windows mobile?

The others libraries is ok(lwuit).

Thks.

2008/10/6 Hinkmond Wong

> Renato Fagalde wrote:
>
>> hi everybody!
>>
>> I have a ready application that runs on Symbian 6, I'm using the
>> JSR172, to handle communication via the Web (also use the lwuit). Now that
>> this application can not run on Windows Mobile.
>>
>> How can I do to make the application works on Windows Mobile?
>>
>
> Hi Fagalde,
>
> What type of error do you see? What is the exact output message and
> incorrect behavior when you say it "cannot run"?
>
> Hinkmond
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: advanced-unsubscribe@phoneme.dev.java.net
> For additional commands, e-mail: advanced-help@phoneme.dev.java.net
>
>

--
Renato Fagalde
11 - 8266-6522
[att1.html]

Davy Preuveneers

On Tuesday 07 October 2008, Renato Fagalde wrote:
> Hello!
>
> The problem is when you open a class that will handle the connection to
> the Web Services(stubs), then won the exception
> java.lang.NoClassDefFoundError
>
> how do I turn the specification jsr172 in windows mobile?
>
>
> The others libraries is ok(lwuit).
>
>
> Thks.

This is what I do to include JSR 172 support in my Windows Mobile pMEA builds
with MIDP support. I just set the following environment variables:

export USE_MIDP=true
export CVM_DUAL_STACK=true
export USE_JSR_172=true

You did not mention which class is causing the error. Is it a class of the JSR
172 specification itself or a class of your web service proxy classes? Are
you sure you have set the classpath correctly?

Best regards,
Davy

---------------------------------------------------------------------
To unsubscribe, e-mail: advanced-unsubscribe@phoneme.dev.java.net
For additional commands, e-mail: advanced-help@phoneme.dev.java.net

Renato Fagalde

Hi Davy,

In the error message that appears only appears NoClassDefFoundError, but not
to be informed or StackTrace class, as this will only occur in the cell can
not see the error details.

The pMEA, is a KVM or is an emulator for PC?

Thank you for your attention
Fagalde

2008/10/7 Davy Preuveneers

> On Tuesday 07 October 2008, Renato Fagalde wrote:
> > Hello!
> >
> > The problem is when you open a class that will handle the connection
> to
> > the Web Services(stubs), then won the exception
> > java.lang.NoClassDefFoundError
> >
> > how do I turn the specification jsr172 in windows mobile?
> >
> >
> > The others libraries is ok(lwuit).
> >
> >
> > Thks.
>
> This is what I do to include JSR 172 support in my Windows Mobile pMEA
> builds
> with MIDP support. I just set the following environment variables:
>
> export USE_MIDP=true
> export CVM_DUAL_STACK=true
> export USE_JSR_172=true
>
> You did not mention which class is causing the error. Is it a class of the
> JSR
> 172 specification itself or a class of your web service proxy classes? Are
> you sure you have set the classpath correctly?
>
> Best regards,
> Davy
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: advanced-unsubscribe@phoneme.dev.java.net
> For additional commands, e-mail: advanced-help@phoneme.dev.java.net
>
>

--
Renato Fagalde
11 - 8266-6522
[att1.html]