Skip to main content

6u10 rc2 javaw.exe no longer has the xp theme dependency in its manifest

4 replies [Last post]
perrito666
Offline
Joined: 2006-08-20
Points: 0

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
kirillcool
Offline
Joined: 2004-11-17
Points: 0

Looks like it is part of http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6722527

I liked this line from the bug evaluation: "I'm not sure if it's a good idea for Deployment engineers to be messing around with other teams Makefiles...and the Deployment team probably shouldn't be responsible for testing the other teams' binaries with their new manifests."

kirillcool
Offline
Joined: 2004-11-17
Points: 0

https://bugs.eclipse.org/bugs/show_bug.cgi?id=247046 for more information, including the fix that should be available in the next build (b33).

kirillcool
Offline
Joined: 2004-11-17
Points: 0

Is this change also making Eclipse running on 6u10 not use the Vista control set? I have wasted so much time over the last few days uninstalling all the Windows updates that i could think of and reconfiguring the machine, only to find out that if i switch to 5.0_15 then Eclipse (SWT) is back on track.

Kirill

perrito666
Offline
Joined: 2006-08-20
Points: 0

> Is this change also making Eclipse running on 6u10
> not use the Vista control set?

I am not sure if this is the same problem, eclipse has it's own launcher so probably shouldn't be impacted by the lack of the dependency in the manifest of javaw.exe

Message was edited by: perrito666