Skip to main content

Can i install the lg3d-core_1.0.1_dev_i686.deb package in Hardy amd64?

4 replies [Last post]
2two2
Offline
Joined: 2008-09-15
Points: 0

I'm trying to install lg3d on Ubuntu 8.04 64-bit. The latest deb package is only available for i386.

lg3d-core_1.0.1_dev_i686.deb

Is it possible to install that package on amd64? I can rebuild the deb package for amd64 but I wanted to make sure that it's not going to cause any errors to occur before I try to install it. Anyone had any success installing it on amd64?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
William Tracy

On Mon, Sep 15, 2008 at 7:09 PM, wrote:
> Is it possible to install that package on amd64?

LG3D itself is all Java code, so it shouldn't care about the 32/64 bit
issue. However, I think the LG3D package includes a Java runtime,
which generally does care.

I can't remember what bits of the runtime are actually included now.
If the entire runtime (JRE + Java3D) is all in the package, then the
32 bit runtime should work on a 64 bit OS. However, if it's only
Java3D, the 32-bit Java3D might conflict with whatever 64-bit package
is supplying the JRE.

Take a look at what the package depends on; if it depends on any
external Java packages, there might be an issue. If not, just try
installing it.

I hope that tides you over until someone who knows what's really going
on shows up. :-)

--
William Tracy
afishionado@gmail.com -- wtracy@calpoly.edu

"We need a special holiday to honor the countless kind souls with
unsecured networks named 'linksys'."
-- Randall Munroe

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@lg3d.dev.java.net
For additional commands, e-mail: interest-help@lg3d.dev.java.net

2two2
Offline
Joined: 2008-09-15
Points: 0

Thanks for your reply. The following is taken from the control file in the deb package.

Provides: lg3d-core
Depends: sun-java6-jdk

I assume that when the lg3d-core package is installed it will download the 64-bit version of sun-java6-jdk from the Ubuntu repository. Will that cause any problems if it's used with a 32-bit lg3d-core?

Amir Bukhari

lg3d in app mode (lg3d-app) has no support for 64 bit, because the
compiled version of Xvfb which used by LG3D APP MODE is 32bit.

but 64bit java will also work in Lg3d but only in lg3d-dev mode, that
mean you can't run x11 application inside LG3D. but if you installed the
32bit java, you can run LG3D in app mode.

-Amir

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@lg3d.dev.java.net
For additional commands, e-mail: interest-help@lg3d.dev.java.net

William Tracy

On Thu, Sep 18, 2008 at 2:22 AM, Amir Bukhari wrote:
> but 64bit java will also work in Lg3d but only in lg3d-dev mode, that mean
> you can't run x11 application inside LG3D. but if you installed the 32bit
> java, you can run LG3D in app mode.

The only thing that concerns me is that I think the lg3d .deb includes
the Java3D extension, and that would be a 32-bit extension.

*If* the VM you have installed is 32-bit, go right ahead with the LG3D package.

Otherwise, I would suggest installing Java3D and LG3D manually, rather
than via the .deb files. Grab the version of Java3D that matches your
VM here:
https://java3d.dev.java.net/binary-builds.html

(32-bit Java3D if you have a 32-bit VM, 64-bit if your VM is 64-bit.)
I haven't tried installing Java3D manually on top of the VM from a
package, so I can't tell you what path you'd have to install to. It
might be easier to install the VM manually, too.

As Amir mentioned, app-mode will probably not work, and you will be
limited to native LG3D applications.

--
William Tracy
afishionado@gmail.com -- wtracy@calpoly.edu

"We need a special holiday to honor the countless kind souls with
unsecured networks named 'linksys'."
-- Randall Munroe

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@lg3d.dev.java.net
For additional commands, e-mail: interest-help@lg3d.dev.java.net