Skip to main content

building midp for arm wince error occurred

10 replies [Last post]
geelpheels
Offline
Joined: 2006-05-05

What error can cause the error message?

......
Serial communication is not implemented yet for OS wince
Serial port communication is not implemented yet for OS wince
resources.res : warning LNK4221: no public symbols found; archive member will be
inaccessible
resources.res: not found
archive: not found
make: *** [D:/phoneme_feature_mr3/phoneme_feature_wince_arm_evc/build_output/mid
p/obj/arm/libobj.lib] Error 127

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
geelpheels
Offline
Joined: 2006-05-05

This is because the command is not recognized by the cyg4me shell. Modify the command in the makefile such remove the quotes on some filename will work.

george_ustc
Offline
Joined: 2008-08-26

I saw the problem too. It seems it caused by some of makefile for runmidlet is not correct on wince, particularly the "ar" command don't work on wince. please try to find the position of these sentences and change it according with wince.

geelpheels
Offline
Joined: 2006-05-05

george_ustc:
Thanks a lot. Can you tell me how you managed to correct this this error?

geelpheels
Offline
Joined: 2006-05-05

What happened?

geelpheels
Offline
Joined: 2006-05-05

No body see this phenomenon?

geelpheels
Offline
Joined: 2006-05-05

......

geelpheels
Offline
Joined: 2006-05-05

Please don't just look!

geelpheels
Offline
Joined: 2006-05-05

No one encountered such error?

geelpheels
Offline
Joined: 2006-05-05

If I run build midp again, it at all ended and runMidlet.exe was generated. When I run it on a smartphone with wince, the selection ui displayed but in less than one second, the program exited with an error reported.

geelpheels
Offline
Joined: 2006-05-05

Please don't just look!