Skip to main content

Eclipse plugin 1.0.6 does not add new servers for Eclipse 3.3.2

1 reply [Last post]
jthoennes
Offline
Joined: 2008-03-06

Hello,

using the JEE perspective, view Servers, New / Server I get the
Define a New Server dialog.

Using the link "Download additional server adapters" I downloaded the Glassfish support and restarted Eclipse.

But the Glassfish support is not added to the above dialog.

Help / About Eclipse / Configuration details shows:

...
com.sun.enterprise.jst.server.sunappsrv (1.0.6) "Sun Application Servers and GlassFish Servers support" [Installed]
...
ID: com.sun.enterprise.jst.server.sunappsrv.feature, Version: 1.0.6
...

Any idea what went wrong?

Do you need specific patch for WST or JST?

Thanks, Jörg

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
raccah
Offline
Joined: 2004-03-04

You may be running into this eclipse problem https://bugs.eclipse.org/bugs/show_bug.cgi?id=246208

Basically, the newer glassfish plugins require a newer eclipse, but eclipse does not stop you from installing them, so you end up with unsatisfied dependencies.

1.0.3 of the plugin is the last version that can be used with Eclipse < 3.4. You can manually install an older version using https://glassfishplugins.dev.java.net/download/index.html if you'd like.