Skip to main content

why LWUIT theme UI resource editor often get EOFException

2 replies [Last post]
ousys
Offline
Joined: 2008-05-14
Points: 0

Hello , now I use LWUIT for doing my final year project, and I think the theme UI resource editor is very helpful ,then I could do nice things in graphical environment . And we set up build.xml files as

which added in element

and somehow it works well for the first time.
Then I modified my source code, I run the program again , it throws EOFException , and the FYp.res automatically became very small (before it is 12k, and the second time I run the program it became 6 k)

I don't know WHAT IS WRONG? how to solve this problem? is it the problem of setting up (but why we can run it successfully for the first time)? then is it the problem of the UI editor? if it is , what to do can help my Final year project?

Looking forward for your replies. Thank you!

you can directly contact me by ousysrobin@gmail.com
^__^

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ousys
Offline
Joined: 2008-05-14
Points: 0

Thank you , shai , Now I find what I could do if EOFException happened, the only thing I should do is replace the corrupted file with the original files under complied folder and preverified folder, and run again...it can work well for some times, until next EOFException, and do the same thing...^__*
still dunno what cause the EOFException Problem...
however , the build.xml file is not builted by ant, it is written by myself, so maybe I should read some chapters about how to use ant for this LWUIT theme visual studio.

Shai Almog

Hi ousys,
you are using the ant task to generate resources. The resource editor
is a separate visual tool.

Do you use NetBeans to build?

Turn on verbosity for ant in order to see if anything failed during
build causing the resource file size to become 0. The logical names
of your fonts look incorrect so I assume that is the reason something
failed.
Please review the resource section in the developer guide regarding
the ant task.

Thanks,
Shai.

> Hello , now I use LWUIT for doing my final year project, and I
> think the theme UI resource editor is very helpful ,then I could do
> nice things in graphical environment .
> And we set up build.xml files as
>
> > classname="com.sun.lwuit.resource.Builder" name="build"/>
>
> > charset=" ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz-02."/>
> > name="Font 4"
> charset="ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz-02."/>
>
>

>

>
> and somehow[b] it works well for the first time[/b]. Then I
> modified my source code, I [b]run the program again , it throws
> EOFException[/b] , and the FYp.res automatically became very small
> ([b]before it is 12k, and the second time I run the program it
> became 6 k, I don't know WHAT IS WRONG? how to solve this problem?[/b]
> is it the problem of setting up (but why we can run it successfully
> for the first time)?
> then is it the problem of the UI editor? if it is , what to do can
> help my Final year project?
>
> Looking forward for your replies. Thank you!
> [Message sent by forum member 'ousys' (ousys)]
>
> http://forums.java.net/jive/thread.jspa?messageID=286003
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@lwuit.dev.java.net
> For additional commands, e-mail: users-help@lwuit.dev.java.net
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@lwuit.dev.java.net
For additional commands, e-mail: users-help@lwuit.dev.java.net