Skip to main content

Glassfish plugin will not install server adapter

7 replies [Last post]
pihlenfeldt
Offline
Joined: 2008-05-14
Points: 0

I downloaded Eclipse 3.3.2 Europa available at http://www.eclipse.org/downloads/ ("Eclipse IDE for Java EE Developers"). Clean install.

I then installed Glassfish using glassfish-installer-v2ur2-b04-windows.jar.Glassfish is functional. I deployed the test war, and then eventually got my own app up and running in Glassfish.

My question is regarding the Glassfish plugin. I followed the instructions available at: https://glassfishplugins.dev.java.net/eclipse33/index.html, and after the install I have no new Glassfish adapter category like the instructions say I will. I therefore can't create a "server" entry, and can't integrate the IDE and the app server.

I have seen some discussion regarding directory permissions, but that shouldn't be an issue. I'm running Windows XP.

I have reinstalled Eclipse and re-tried the plugin configuration several times now, and am at a loss to figure out why this is happening. If you have encountered and resolved this situation, I would appreciate any help you might have to offer.

Thank you

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
vbkraemer
Offline
Joined: 2003-09-03
Points: 0

I will have a go at replicating this...

The install process has worked pretty much every time for me...

Do you see any messages in the log file for Eclipse?

What kind of environment are you running in? (jdk, os, etc)

vbk

pihlenfeldt
Offline
Joined: 2008-05-14
Points: 0

I eventually had someone else (for whom the install was going ok) just zip and send me a working Eclipse installation with the Plugin already installed. So, I guess I should close this. My apology... I forgot to close this post. Please don't spend any time on this. Everyone told me "the installation works every time" for them as well. No idea what the deal was for me. I never was able to determine what was actually going wrong. All I wanted to do was work on the actual application I was constructing. I didn't have any time to debug Eclipse, know what I mean? I'm going to set this one to "answered". I very much appreciate our willingness to help though. Thank you.

leoneri
Offline
Joined: 2008-04-20
Points: 0

Hi, sorry for digging up old forum.

But I do not think this thread should be closed. Because (finally) for the very first time, I experience it. I installed the Glassfish adapter, restart my eclipse, and I got nothing ... I tried again, but still the same.

My environment:
* Windows 2000 running on Parallel virtual machine on Mac OSX
* JDK 1.5.10 (needed for development)

I didn't see any error or log (as I also do not know where to find it), there is no any warning during downloading and installation.

If anyone put "how to manually install glassfish server adapter eclipse" on Google, you'll see some people experience the same thing ...

regards.

raccah
Offline
Joined: 2004-03-04
Points: 0

Which version of eclipse are you running? You may be running into this eclipse problem https://bugs.eclipse.org/bugs/show_bug.cgi?id=246208

Basically, the newer glassfish plugins require a newer eclipse, but eclipse does not stop you from installing them, so you end up with unsatisfied dependencies.

jmandawg
Offline
Joined: 2008-09-29
Points: 0

What version of the plugin do you need to install for eclipse europa 3.3? 1.0.11 does not work with it.

jmandawg
Offline
Joined: 2008-09-29
Points: 0

Nevermind:
Starting from this plugin version, Eclipse 3.4 is required

pihlenfeldt
Offline
Joined: 2008-05-14
Points: 0

FYI - also just looked at an article ( http://kaypress.kayrin.com/?p=220 ) by someone who claims to have been able to install it manually. Didn't work for me. I unzipped everything the way this person describes, restarted Eclipse... still no Glassfish in the new server dialog.

Anyone?