Skip to main content

web service client reference is not updated after a redeploy

3 replies [Last post]
tololo
Offline
Joined: 2007-10-16

Hello!
i hope you can help me.

i have a web service client, the web service classes have some static Wrappers that i am accesing to get into the web service.

everything works fine with the exception that when i do a redeploy, then the web services stop working.

in GlassfishV1 i used to get an Exception about accessing an already trashed object. In V2 i don't get any exception of this kind.

to get the web services to work again i have to restart the domain (which is not a good practice once you are in production phase.. which is the case now).

do any of you have experienced any similar problems? .... any ideas that you might have that could help me?.. thanks in advance
cheers
tololo

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
roisinflannery
Offline
Joined: 2007-05-08

Hi tololo,

Have you ever considered purchasing a support contract with Sun? We have a number of different offerings and pricing schemes, to support every type of user.

With support, you receive access to fully tested and supported patches, containing fixes to recent bugs. You also will have the benefits of up to 24x7 support, meaning that you can get your questions answered all the time anytime. Please take a look at the following link for more details:
http://forums.java.net/jive/thread.jspa?messageID=276262&#276262
or else, please feel free to reply to this thread and I will provide more information.

Kind regards,
Roisin
Sustaining Engineering, GlassFish

bhaktimehta
Offline
Joined: 2004-03-18

Pls can you file a but and send your sources so I can reproduce this problem
Thanks,
Bhakti

bhaktimehta
Offline
Joined: 2004-03-18

Sorry I meant file a bug and send your sources