Skip to main content

Missing required modules for Plugin JavaFX Editor:

6 replies [Last post]
hutu
Offline
Joined: 2006-04-21
Points: 0

New HP 64-bit vista machine, newly installed JDK6 with netbeans 6.1.
When I tried to install javaFX:

Missing required modules for Plugin JavaFX Editor:
module org.netbeans.api.gsf/1 > 0.40.0 module org.netbeans.api.gsfpath/1 > 0.32 Common Scripting Language Support [module org.netbeans.modules.gsf/1 > 0.51]

Any idea?

Thanks

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jerred
Offline
Joined: 2008-05-12
Points: 0

The latest version of NetBeans does not work with the JavaFX plugin. I imagine this will be fixed in a later release but for now you can download an earlier version of NetBeans at: http://download.netbeans.org/netbeans/6.0/final/

s_ravi_kumar
Offline
Joined: 2008-06-23
Points: 0

true, 6.1 still now doesnt have support for JavaFx even though they claim.

javafx.navigation is the error resulting..

alexsch
Offline
Joined: 2007-07-12
Points: 0

The issue with javafx.navigation dependency has been fixed:
http://www.netbeans.org/issues/show_bug.cgi?id=138192

One more problem is that Palette does not add correct imports now because
of the recent package structure changing in Reprise:
http://www.netbeans.org/issues/show_bug.cgi?id=137847

alexsch
Offline
Joined: 2007-07-12
Points: 0

You need to use the latest NetBeans 6.1 and follow downloading and installing instructions from http://javafx.netbeans.org/download-compiler-JFXplugin.html

If it does not work for you then attach the IDE log file. It can help to investigate the problem.

hutu
Offline
Joined: 2006-04-21
Points: 0

My NetBeans is the latest.

When I check update: "There are no updates available."

Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)

could it be x64 bit vista OS?

hutu
Offline
Joined: 2006-04-21
Points: 0

Fixed and installed JavaFX Kit

but same problem with weather sample:

Missing required modules for Plugin JavaFX Editor:
module org.netbeans.api.gsf/1 > 0.40.0 module org.netbeans.api.gsfpath/1 > 0.32 Common Scripting Language Support [module org.netbeans.modules.gsf/1 > 0.51]

I do have Kit 2008-04-18_14-52-03 installed