Skip to main content

Problem installing Glassfish v2 server adapter to Eclipse R3.4M6/WTP 3.0M6

3 replies [Last post]
jmordax
Offline
Joined: 2008-03-18
Points: 0

It shows an error when trying to install:

The site is not updateable: file:/D:/eclipse-SDK-3.4M6a-win32/.

Following is the complete error message from Product Configuration:

Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
----- Current configuration problems -----
WST Web Services Core (3.0.0.v200804012222-7D7CECWEB7sQS8R9bGheoE) requires plug-in "org.eclipse.xsd (2.3.0)", or compatible.
WST Web Services UI (3.0.0.v200804012222-7B2EDkBqiaacbumnZouVIjJuS4fp) requires plug-in "org.eclipse.xsd (2.2.0)", or compatible.
JST Enterprise UI (3.0.0.v200804020355-7Y7BFCwEPOwQJGL-ANhrqTNfSqjT) requires plug-in "org.eclipse.xsd (2.2.0)", or compatible.
Eclipse XML Editors and Tools (3.0.0.v200804020355-7C2EC_Cnfcx2hmpktkvWZdz0j9s_) requires plug-in "org.eclipse.xsd.edit (2.2.0)", or compatible.
WST XML Core (3.0.0.v200804020355-7A7NEFGE7QYGHMHkHrP9TW) requires plug-in "org.eclipse.xsd (2.2.0)", or compatible.
Java Persistence API Tools (2.0.0.v200802270000-7938aCYQCD4CZHcCCCD) requires plug-in "org.eclipse.xsd".
----- Configuration problems after the operation -----
GlassFish Java EE 5 Server (1.0.2) The site is not updateable: file:/D:/eclipse-SDK-3.4M6a-win32/.
WST Web Services Core (3.0.0.v200804012222-7D7CECWEB7sQS8R9bGheoE) requires plug-in "org.eclipse.xsd (2.3.0)", or compatible.
WST Web Services UI (3.0.0.v200804012222-7B2EDkBqiaacbumnZouVIjJuS4fp) requires plug-in "org.eclipse.xsd (2.2.0)", or compatible.
JST Enterprise UI (3.0.0.v200804020355-7Y7BFCwEPOwQJGL-ANhrqTNfSqjT) requires plug-in "org.eclipse.xsd (2.2.0)", or compatible.
Eclipse XML Editors and Tools (3.0.0.v200804020355-7C2EC_Cnfcx2hmpktkvWZdz0j9s_) requires plug-in "org.eclipse.xsd.edit (2.2.0)", or compatible.
WST XML Core (3.0.0.v200804020355-7A7NEFGE7QYGHMHkHrP9TW) requires plug-in "org.eclipse.xsd (2.2.0)", or compatible.
Java Persistence API Tools (2.0.0.v200802270000-7938aCYQCD4CZHcCCCD) requires plug-in "org.eclipse.xsd".

Any idea about the origin of this problem?

Thanks in advance,

Chemi.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jmordax
Offline
Joined: 2008-03-18
Points: 0

Right. I have tested with RC3 today and it works now.

Regards,

Chemi.

jmordax
Offline
Joined: 2008-03-18
Points: 0

I have tested also with the final Eclipse R3.4 and WTP 3.0 successfully.

Regards,

Chemi.

vbkraemer
Offline
Joined: 2003-09-03
Points: 0

I haven't run into this with Ganymede RC1. You may want to try that release. I got it from here: http://www.eclipse.org/downloads/packages/

vbk