Skip to main content

does Sip RA support TCP?

3 replies [Last post]
cmaluenda
Offline
Joined: 2007-10-28

Hi,
I am not sure if Sip RA support TCP.
jain-sip support and I saw some properties file for configure, but I feel there is something wrong because the var confValue always comes with UDP value (never with TCP).

I compile using ant, but I have to deploy using the web manager (I have a null pointer Exception when I try to deploy the R.A.).

I don't know where I have to configure the transport TCP, because the FlashLite client doesn't support UDP.

Cheers,
Cristian.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
cmaluenda
Offline
Joined: 2007-10-28

I found the way to use TCP, but I had to change the code in:
org.mobicents.slee.resource.sip.SipResourceAdaptor

If I add the transport in the file resource-adaptor-jar.xml:

List of transports, separated with ","
transports
java.lang.String
UDP,TCP

The problem is: I can add the property in the descriptor file, but the Class SipResourceAdaptor doesn't have TCP in the allowedTransports (Only expect "udp" and is case sensitivity). So, If I add TCP in the allowedTransports works.

When start the services I have this error message:
2008-03-17 14:09:21,417 ERROR [STDERR] javax.slee.resource.ResourceException: class org.mobicents.slee.resource.sip.SipResourceAdaptor should implement property accessor method java.lang.Long getCancelWait()

And when I try to send a message I have this error:
2008-03-17 14:19:40,526 INFO [org.mobicents.slee.resource.sip.SipResourceAdaptor]
-------------------------
REQUEST:
-------------------------
MESSAGE sip:c@192.168.1.183 SIP/2.0
Call-ID: 6d8f1981a82017d4ceccab51df178871@0.0.0.0
CSeq: 23826509 MESSAGE
From: "n" ;tag=58ee7879
To:
Via: SIP/2.0/TCP 192.168.1.183:19635;rport=19635;branch=z9hG4bKbb5d66d80153258771c508b7c5bc52fd
Max-Forwards: 70
Content-Type: text/plain
Content-Length: 4

hola
-------------------------
2008-03-17 14:19:40,542 ERROR [STDERR] 17/03/2008 14:19:40 org.mobicents.slee.services.sip.proxy.ProxySbb prepareENV
INFO: [SipProxy][^^^][No conf present, obtainign one]
2008-03-17 14:19:40,542 ERROR [STDERR] 17/03/2008 14:19:40 org.mobicents.slee.services.sip.proxy.ProxyMachine forwardRequest
INFO: Forwarding request MESSAGE of server tx z9hG4bKbb5d66d80153258771c508b7c5bc52fd
2008-03-17 14:19:40,557 INFO [org.mobicents.slee.resource.sip.SipResourceAdaptor]

baranowb
Offline
Joined: 2006-01-09

Shouldnt happen happen, that error either.
I know there is somee kind of error on certain jvm, properties are not initialized properly. Will take a look.

baranowb
Offline
Joined: 2006-01-09

DOnt start multiple threads with the same content, its confusing.
It was a small bug, forgot to add tcp into allowed transports, plus comparizon was a little akward, its fixed, waiting for release to commit.