Skip to main content

How to wrap DOJO 1.0.3 widgets with JMaki?

3 replies [Last post]
marklv
Offline
Joined: 2008-02-06
Points: 0

Hi,

I am also interested using JMaki with dojo version greater then 1.0
As I understood you are currently working on wrappers for DOJO 1.0.2
When it might be released? And do you have an updated documents on how to wrap a widget in JMaki for DOJO 1.0.2 widgets?
(Something like this document:
http://java.sun.com/developer/technicalArticles/J2EE/webapp_2/
but for DOJO 1.0.2 and latest version of JMaki.)

Thank
Mark

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
carlavmott
Offline
Joined: 2005-02-10
Points: 0

Hi Mark,

I just posted the bundle for the Dojo 1.0.2 release. See my post at
http://forums.java.net/jive/thread.jspa?threadID=36399

We have been asked for a document on wrapping widgets and I will try and something out in the next week.

Carla

marklv
Offline
Joined: 2008-02-06
Points: 0

Hi,

I am trying to insert the JMaki to my application
However I get an erro saying that the jmaki is undefined
I put the dojo folder under my web application folder and the
ajax-wrapper-comp-1.0.3.jar under the WEB_INF\lib directory, together with the org.json-0.0.1.jar.
do I need to put something else?

Thanks Mark

carlavmott
Offline
Joined: 2005-02-10
Points: 0

You need to have a tag lib definition at the top of you jsp page and the supporting jmaki script files.
jmaki.js and config.json in resources.

config.json:
{
'config': {
'version': '1.0',
'glue' : {
'includes': ['/glue.js', '/resources/system-glue.js']
}
}
}
jsp tag is :

<%@ taglib prefix="a" uri="http://jmaki/v1.0/jsp" %>

in the Java bundle for jMaki 1.0 you will find an ant task which builds a bare bones jMaki app. There are no toolkit libs in the app just what is needed for jMaki. See the 'core' directory for the build.xml file and type ant.

Carla