Skip to main content

JMaki and Dojo 1.0.3

4 replies [Last post]
jedsmallwood
Offline
Joined: 2008-01-25

I am currently evaluating JMaki for use as a JSF wrapper for the DOJO toolkit. An important aspect of Dojo 1.0.x is that it is 508 compliant. Looking into the JMaki 1.0.3 distribution, it appears that Dojo 0.4.3 is being used as opposed to 1.0.3. Is it possible to "swap" out the version of Dojo shipped with JMaki?

If not, are there plans to update JMaki to include Dojo 1.0.3?

Thanks,
Jed

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
marklv
Offline
Joined: 2008-02-06

Hi,

I am also interested using JMaki with dojo version greater then 1.0
As I understood you are currently working on wrappers for DOJO 1.0.2
When it might be released? And do you have an updated documents on how to wrap a widget in JMaki for DOJO 1.0.2 widgets?
(Something like this document:
http://java.sun.com/developer/technicalArticles/J2EE/webapp_2/
but for DOJO 1.0.2 and latest version of JMaki.)

Thank
Mark

carlavmott
Offline
Joined: 2005-02-10
sloanb
Offline
Joined: 2003-09-14

We are currently working on wrappers for Dojo 1.0.2 at the moment. As for your question regarding swapping out dojo shipped with jMaki do you mean replacing the 4.3 library with the 1.0.2 and the widgets working? If this is your question then the answer is no this will not work. A new set of the dojo dijit widgets are being developed for the 1.0.2 release of dojo for jMaki.

So are they plans? Yes we are in the development right now.

jedsmallwood
Offline
Joined: 2008-01-25

You interpreted my questions correctly. Thanks for the prompt reply.