Skip to main content

ClassDefFoundError: org.json.jsonexception

2 replies [Last post]
bonsai
Offline
Joined: 2008-01-10
Points: 0

Hi
I still have problems with jMaki. When I put widgets on a side I always get follow error:

javax.servlet.ServletException: java.lang.NoClassDefFoundError: org/json/JSONException
org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:850)
org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:779)
org.apache.jsp.hello_jsp._jspService(hello_jsp.java:82)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:393)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

root cause

java.lang.NoClassDefFoundError: org/json/JSONException
jmaki.runtime.AjaxContext.(AjaxContext.java:117)
jmaki.runtime.AjaxContext.getInstance(AjaxContext.java:67)
jmaki.runtime.AjaxContext.getInstance(AjaxContext.java:82)
jmaki.runtime.jsp.AjaxTagBase.doStartTag(AjaxTagBase.java:33)
org.apache.jsp.hello_jsp._jspx_meth_a_005fwidget_005f0(hello_jsp.java:103)
org.apache.jsp.hello_jsp._jspService(hello_jsp.java:70)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:393)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:320)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

I use Eclipse 3.3.1.

Olly

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
bonsai
Offline
Joined: 2008-01-10
Points: 0

fixed

bonsai
Offline
Joined: 2008-01-10
Points: 0

Hi
I fixed the Error. I have found a package org.json-0.0.1.jar and have put it to the project. But now I'm getting an Runtime Error.

Olly