Skip to main content

jmake Eclipse Wizard Error

7 replies [Last post]
pauljh
Offline
Joined: 2008-01-10
Points: 0

Hello All,

I installed the latest eclipse 3.3.1.1 and the jmaki eclipse plugin. I created a dynamic web project. When I used the jmaki Stylized wizard I get an error with no message. I selected jmaki-standard in the wizard. Also, I see all of mine jmaki snippets are present in the Snippets tab. What I am doing wrong?

Thanks

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
bonsai
Offline
Joined: 2008-01-10
Points: 0

Literal Error:
The Wizard is now working.

bonsai
Offline
Joined: 2008-01-10
Points: 0

Thanks for the fix. The Wizard is no working.

But when I still get a Runtime-Error when I try to use a jsp-side with widget. Can you help me?

Thanks
Olly

ludo
Offline
Joined: 2003-06-10
Points: 0

fixed.
Stop Eclipse.
Delete all directories that contain jmaki in the name for eclipse/plugins and eclipse/features.
Restart the ide and get the updated jmaki plugin from the update center

Thanks,
Ludo

ludo
Offline
Joined: 2003-06-10
Points: 0

We are testing a fix. Will Publish tomorrow,

Ludo

bonsai
Offline
Joined: 2008-01-10
Points: 0

Hi
I have found out, that the MANIFEST.MF in the plugin is incorrect.
The bundle-Version is wrong.
Here the correct MANIFEST.MF. Change Version from 1.0 to 1.0.3

But when I do this, I get another error:
Plug-in: "org.jvnet.ajax.eclipse.jmaki" version: "1.0.3" referenced by this feature is not included at runtime. Runtime includes plug-in version "1.0.3" supplied by feature "jMaki Feature" version "1.0.3".

Some idea?

Manifest-Version: 1.0
Bundle-ManifestVersion: 3
Bundle-Name: JMaki Plug-in
Bundle-SymbolicName: org.jvnet.ajax.eclipse.jmaki;singleton:=true
Bundle-Version: 1.0.3
Bundle-Activator: org.jvnet.ajax.eclipse.jmaki.JMakiPlugin
Bundle-Localization: plugin
Require-Bundle: org.eclipse.gef,
org.eclipse.ui.ide,
org.eclipse.ui.workbench.texteditor,
org.eclipse.jface.text,
org.eclipse.core.resources,
org.eclipse.core.runtime,
org.eclipse.core.runtime,
org.eclipse.wst.common.snippets,
org.eclipse.jst.j2ee,
org.eclipse.jst.j2ee.core,
org.eclipse.jst.j2ee.web,
org.eclipse.core.runtime,
org.eclipse.core.resources,
org.eclipse.wst.common.frameworks,
org.eclipse.wst.common.project.facet.core,
org.eclipse.ui.ide,
org.eclipse.ui.workbench.texteditor,
org.eclipse.emf.edit.ui
Eclipse-LazyStart: true
Bundle-Vendor: java.net
Export-Package: org.jvnet.ajax.eclipse.jmaki,
org.jvnet.ajax.eclipse.jmaki.project.facet,
org.jvnet.ajax.eclipse.jmaki.wizards

Olly

polyenergy
Offline
Joined: 2008-01-14
Points: 0

Hello! I do have the same problem. I have downloaded and installed JMaki V.1.0.3 three times and I've got that error message in blank. What should we do now ?

bonsai
Offline
Joined: 2008-01-10
Points: 0

Hi
I've got the same error.
I found out, that the Eclipse PlugIn is not correct installed. When I check the status of the plugin there is an error.
Plug-in "org.jvnet.ajax.eclipse.jmaki" version "1.0.3" referenced by this feature is missing.

But at the moment I don't know how to fix this.

Do you have solved your problem?

Olly