Skip to main content

[No Subject]

2 replies [Last post]
Anonymous

Hello
my operating system is Linux Ububtu .
I use NetBeens 6.0
but when I whant to run a MIDP program I have following error
/*
NetBeansProjects/VDCustomComponents1/dist//VDCustomComponents1.jad
Starting emulator in execution mode
Exception in thread "main" java.lang.UnsupportedClassVersionError:
com/sun/kvem/environment/EmulatorWrapper (Unsupported major.minor
version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
*/
please help me
with very thanks
mohammad goli khatir

===========================================================================
To unsubscribe, send email to listserv@java.sun.com and include in the body
of the message "signoff KVM-INTEREST". For general help, send email to
listserv@java.sun.com and include in the body of the message "help".

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ahmed_belgacem
Offline
Joined: 2008-07-03

i have the same problem. i work under Ubuntu Linux and that's a big problem for me

sfitzjava
Offline
Joined: 2003-06-15

Looks like you don't have the Mobility pack setup for NB6, or the project isn't setup as a JavaME project. It looks like the classloaders are not finding the correct version of the class files which could be caused by the code being compiled for a Java version > 1.1 (the typical JavaME version) and when the KVEM tries to start it gets a class mismatch.

-Shawn