Skip to main content

Unable to uninstall webstarts

6 replies [Last post]
matzon
Offline
Joined: 2003-06-10

This is two bugs:
- If you clear the cache in Java from the control panel, you can't uninstall any webstart applications. It tries to remove it - but the add/remove entry is never removed

- If you disable the cache in Java from the control panel, you can uninstall applications. It fails with attached image.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
rogerl
Offline
Joined: 2004-11-15

Thank you for the screen shot!

Before we can open a bug, we need to know a few other points of information.

1) java -version
2) OS info

-Roger

matzon
Offline
Joined: 2003-06-10

yes, sorry - of course:

java version "1.6.0_10-ea"
Java(TM) SE Runtime Environment (build 1.6.0_10-ea-b08)
Java HotSpot(TM) Client VM (build 1.6.0_10-ea-b08, mixed mode, sharing)

Running Windows XP, SP2 - 32bit

rogerl
Offline
Joined: 2004-11-15

Thanks.

I have created a new bug, 6646538
It will take a day or so for it to appear at the the link below:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6646538

Is this still happening with b09?

-Roger

matzon
Offline
Joined: 2003-06-10

yes

rogerl
Offline
Joined: 2004-11-15

We are not able to reproduce the situation where the the application does not uninstall.
Is it possible that you provide us more information on what is happening?

It is likely that some cache corruption is causing the applications to not be removed from the add/remove programs entry when the cache is cleared.

Please reinstall the app that wasn't removed, and then clear the cache again.

If the problem persists with that one app. then you can turn on debugging from inside the Java Control Panel with the following entries in the deployment.properties file:

deployment.trace=true
deployment.trace.level=all

and see the output in jcp.trace and javawsXXXX.trace

-Roger

Message was edited by: rogerl

matzon
Offline
Joined: 2003-06-10

1: Clear cache - fresh start
2: visit http://lwjgl.org/jnlp/lwjgl-demo.php/examples.spaceinvaders.Game, play for a bit :)
3: Clear cache (Temporary Internet Files -> Settings -> Delete files)
4: Open Add/Remove Programs
5: Remove the LWJGL Demo [examples.spaceinvaders.Game] entry
6: Confirm deletion
7: Entry remains

Interresting output from trace:
basic: Uninstall: http://lwjgl.org/jnlp/lwjgl-demo.php/examples.spaceinvaders.Game
network: Cache entry not found [url: http://lwjgl.org/jnlp/lwjgl-demo.php/examples.spaceinvaders.Game, version: null]
network: Connecting http://lwjgl.org/jnlp/lwjgl-demo.php/examples.spaceinvaders.Game with proxy=DIRECT
network: ResponseCode for http://lwjgl.org/jnlp/lwjgl-demo.php/examples.spaceinvaders.Game : 200
network: Encoding for http://lwjgl.org/jnlp/lwjgl-demo.php/examples.spaceinvaders.Game : null
...
network: Cache entry not found [url: http://lwjgl.org/jnlp/lwjgl-demo.php/examples.spaceinvaders.Game, version: null]

I have attached the trace log