Skip to main content

Problems with my first java ME experience... help please

5 replies [Last post]
letal
Offline
Joined: 2007-11-13

Hi everyone,

I have a work to do and after i downloaded every stuff to begin the programming part, i saw that i cant compile the code, using eclipse or jcreator because there arent the necessary libraries. I cant find the place to switch the lib directory. Im very new at this.

After installing the java sun wireless toolkit to emulate the code, when i was testing to create a new project there appears an error saying that i dont have source to compile. i allready installed MIDP 2.1 and CLDC 1.1 but i dont know how can i set this as source.

Best regards.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
terrencebarr
Offline
Joined: 2004-03-04

albe,

Please check out the "Getting Started" URL above. You should find plenty of information to get you started.

-- Terrence

albe
Offline
Joined: 2007-11-27

thanks terrence

i will work out then intimate you

thanks

terrencebarr
Offline
Joined: 2004-03-04

Sorry for the slow reply.

I'm afraid I don't have quite enough information ... seems like some setup or library path problem.

Have you followed our "Getting Started" page?

https://meapplicationdevelopers.dev.java.net/getting_started.html

I suggest you install NetBeans and CLDC Mobility pack and then try to run one of the included demos. Once you succeed with that you can create a new Mobile MIDP application using the wizard in NetBeans. That will set up all libraries and paths correctly and all you need to do is add your source code.

If you still have problem you can post the NetBeans error messages here.

Hope this helps,

-- Terrence

letal
Offline
Joined: 2007-11-13

Thanks for the post, the problem is solved.
Best regards,
Mário Oliveira

albe
Offline
Joined: 2007-11-27

hi

i am very new to JME

can any one help me how to start and improve mysellf in JME