Skip to main content

Error with Pluto installation

3 replies [Last post]
malcovitch
Offline
Joined: 2007-11-05
Points: 0

Hi All,

I'm just starting with portlet programming, and I'm trying to install Pluto using the instructions here:

http://portals.apache.org/pluto/v11/getting-started.html

I have both the binary and the current-bundled versions of Pluto 1.1.4 unzipped. I've successfully the first section; "Installing the Pluto 1.1 Binary Build", so now I'm trying the second section; "Building Pluto from Source - Installing Pluto Manually", following the instructions exactly as they're written. However, I get an the following error on executing "mvn install":

C:\development\pluto-1.1.4>mvn install
[INFO] Scanning for projects...
Downloading: http://repo1.maven.org/maven2/org/apache/apache/3/apache-3.pom
[INFO] ------------------------------------------------------------------------
[ERROR] FATAL ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).

Project ID: org.apache.pluto:pluto:pom:1.1.4

Reason: Cannot find parent: org.apache:apache for project: org.apache.pluto:pluto:pom:1.1.4 for project org.apache.pluto:pluto:pom:1.1.4

Here's the start of the stack trace:

C:\development\pluto-1.1.4>mvn install
[INFO] Scanning for projects...
Downloading: http://repo1.maven.org/maven2/org/apache/apache/3/apache-3.pom
[INFO] ------------------------------------------------------------------------
[ERROR] FATAL ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).

Project ID: org.apache.pluto:pluto:pom:1.1.4

Reason: Cannot find parent: org.apache:apache for project: org.apache.pluto:pluto:pom:1.1.4 for project org.apache.pluto:pluto:pom:1.1.4

C:\development\pluto-1.1.4 is my "local directory where the Pluto 1.1 source distribution has been checked out or unzipped into" (I have the version bundled with Tomcat in another location)

Some info:

C:\development\pluto-1.1.4>mvn -version
Maven version: 2.0.7
Java version: 1.6.0_02
OS name: "windows xp" version: "5.1" arch: "x86"

I've been hunting around for a solution, but with no luck so far. Any help would be much appreciated.

M

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
malcovitch
Offline
Joined: 2007-11-05
Points: 0

Sorry, forgot the stack trace. Here's the output I get after executing mvn install:

[INFO] Scanning for projects...
Downloading: http://repo1.maven.org/maven2/org/apache/apache/3/apache-3.pom
[INFO] ------------------------------------------------------------------------
[ERROR] FATAL ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).

Project ID: org.apache.pluto:pluto:pom:1.1.4

Reason: Cannot find parent: org.apache:apache for project: org.apache.pluto:pluto:pom:1.1.4 for project org.apache.pluto:pluto:pom:1.1.4

[INFO] ------------------------------------------------------------------------
[INFO] Trace
org.apache.maven.reactor.MavenExecutionException: Cannot find parent: org.apache:apache for project: org.apache.pluto:pluto:pom:1.1.4 for project org.apache.pluto:pluto:pom:1.1.4
at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:378)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:290)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:125)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:280)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
Caused by: org.apache.maven.project.ProjectBuildingException: Cannot find parent: org.apache:apache for project: org.apache.pluto:pluto:pom:1.1.4 for project org.apache.pluto:pluto:pom:1.1.4
at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1261)
at org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:747)
at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:479)
at org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:200)
at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:553)
at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:467)
at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:364)
... 11 more
Caused by: org.apache.maven.project.ProjectBuildingException: POM 'org.apache:apache' not found in repository: Unable to download the artifact from any repository

org.apache:apache:pom:3

from the specified remote repositories:
central (http://repo1.maven.org/maven2)
for project org.apache:apache
at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:573)
at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1257)
... 17 more
Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download the artifact from any repository

org.apache:apache:pom:3

from the specified remote repositories:
central (http://repo1.maven.org/maven2)

at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:197)
at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:73)
at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:526)
... 18 more
Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to download the artifact from any repository
at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:324)
at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:185)
... 20 more
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 21 seconds
[INFO] Finished at: Mon Nov 05 16:30:43 GMT 2007
[INFO] Final Memory: 1M/4M
[INFO] ------------------------------------------------------------------------

malcovitch
Offline
Joined: 2007-11-05
Points: 0

I'm using Tomcat 6.0.14.

vforvikash
Offline
Joined: 2008-07-09
Points: 0

Anybody got the solution? Please reply back. Thanks in advance