Skip to main content

MIDP build error on linux - i386 -UnsupportedClassVersionError

No replies
psharma_123
Offline
Joined: 2007-10-22

Hi,
I am trying to build phoneME (phoneme_feature-mr2-rel-src-b23-08_may-2007.zip) on Ubuntu. I am using java version "1.4.2_13".
I am able to build pcsl and cldc but am getting following error while building midp. Any idea why this problem is coming? Which java version should I use?

make[1]: Entering directory `/home/psharma/Jme/phoneme_feature/midp/build/linux_fb_gcc'
... searching updated .java files
... merging configurations
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/sun/xml/transform/CodeTransformer (Unsupported major.minor version 50.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
make[1]: *** [/home/psharma/Jme/phoneme_feature/build_outputn/midp/generated/merged.xml] Error 1
make[1]: Leaving directory `/home/psharma/Jme/phoneme_feature/midp/build/linux_fb_gcc'
make: *** [build_classes] Error 2