Skip to main content

JQS is available for which JVM?

2 replies [Last post]
masanao
Offline
Joined: 2003-06-18

Java Quick Starter is included in JDK6u5.
And Java Quick Starter service seems to use jre6's JVM.

Then Java7 or other version JVMs could be prefetched ?
Or only jre6's JVM starts with JQS?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jmelvin
Offline
Joined: 2004-12-01

JQS will be released with a future JRE 6uX when ready. Each JRE will have it's
own JQS binary and custom config file. The Java Installer/Uninstaller will ensure that
only 1 JQS service is running at any time. Only the latest JRE's JQS should be running.
Running multiple JQS prefetching services will have a dramatic effect on system
responsiveness.

masanao
Offline
Joined: 2003-06-18

Thank you.
I see.
JQS is available for only latest JRE which includes JQS.

But I think there are many situations
that different version JVMs run on one system.
For example , a certain version of JVM is specified in JNLP file.

It is inconvinient JNLP application using Java1.7 starts slowly
while the one using Java1.6 starts quickly.

I hope JQS service allows to prefetch multiple configurations I select.