Skip to main content

Installed over JDK6u3 on XP SP 2, jar application failed to start entirely

3 replies [Last post]
mike__rainville
Offline
Joined: 2004-06-14
Points: 0

Is it possible that some of the packages are not installed and unavailable?
Two smaller, similar applications worked as expected, but the big one fails.
The key difference is that is uses regular expressions, the HTML EditorKit, XML (w3c DOM) and an XSLT transform. (I tried it with and without the quick starter, but same result - no response. The program was compiled with Java 6, update 1 or 2 )

I've attached the imports from the distinctive classes ... (attachment)

It works OK for Firefox, and for my other two JDBC Swing applications.

JEdit 4.3 pre 10 fails the first time, but when I restart it it's fine so far

Best of luck,
Mike R.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
linuxhippy
Offline
Joined: 2004-01-07
Points: 0

well its hard to diagnose the problem with just a list of imports ;)

How/When does it fail, are there exceptions which are thrown, ...

lg Clemens

mike__rainville
Offline
Joined: 2004-06-14
Points: 0

It fails at the very start; there is a 95% CPU spike, and then nothing - there appears to be no activity at all, no exceptions or output of any kind. The first thing that should happen is a Swing dialog to login to a database via an Oracle DataSource (but that's exactly what my OTHER application does.) It could be as simple as the timstamp setting, but based an a lazy loading of classes that may not be used very often, I suspect that one of the packages is not available and something crashes there (just a guess). My hunch would be the javax.xml.transform (XSLT) package because it's probably not used very commonly and it's a very volatile area of java ...

I will start it again at 13:05 Eastern time (Montreal) and leave it running until I get back from lunch, just in case it's really, really. slow. I will also run with verbose and capture everything to a file...

If you want me to try anything else, just ask and I'll put another run in around 3 p.m.

mike__rainville
Offline
Joined: 2004-06-14
Points: 0

The second time I ran it it worked as expected, just like JEdit 10pre3...

Puzzled, but relieved ...

The problem restated, is that an application fails to start on the first run after installing 6u5-ea.