Skip to main content

Can't start Apache TomCat 6.0 on Windows 2003 Server

1 reply [Last post]
xsashimix
Offline
Joined: 2007-10-12
Points: 0

Hi guys,

I do need some help, been trying to debug this for sometime, looked at logs and all. I downloaded TomCat 6.0 and installed the .exe. Everything was smooth and i left most of the settings as default. I'm having problems starting my tomcat 6.0 service in "Configure" on my windows 2003 server. It was unable to start the service after install.

I'm using J2SE JRE 1.4.2_16, I tried 1.6, and same.

Anyone had the same problem or know anything based on these logs below. Thanks!

The error in the logs are:
[2007-10-12 19:46:34] [info] Starting service...
[2007-10-12 19:46:34] [443 javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:46:34] [997 prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:46:34] [1260 prunsrv.c] [error] ServiceStart returned 3
[2007-10-12 19:46:34] [info] Run service finished.
[2007-10-12 19:46:34] [info] Procrun finished.
[2007-10-12 19:46:41] [info] Procrun (2.0.3.0) started
[2007-10-12 19:46:41] [info] Running Service...
[2007-10-12 19:46:41] [info] Starting service...
[2007-10-12 19:46:41] [443 javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:46:41] [997 prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:46:41] [1260 prunsrv.c] [error] ServiceStart returned 3
[2007-10-12 19:46:41] [info] Run service finished.
[2007-10-12 19:46:41] [info] Procrun finished.
[2007-10-12 19:48:41] [443 javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:48:41] [997 prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:48:41] [1260 prunsrv.c] [error] ServiceStart returned 3
[2007-10-12 19:48:48] [443 javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:48:48] [997 prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:48:48] [1260 prunsrv.c] [error] ServiceStart returned 3
[2007-10-12 19:49:55] [443 javajni.c] [error] FindClass org/apache/catalina/startup/Bootstrap failed
[2007-10-12 19:49:55] [997 prunsrv.c] [error] Failed loading main org/apache/catalina/startup/Bootstrap class C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin\bootstrap.jar
[2007-10-12 19:49:55] [1260 prunsrv.c] [error] ServiceStart returned 3

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
tomitzel
Offline
Joined: 2006-08-08
Points: 0

I've got the same problem, but with win xp :(