Skip to main content

Getting an error while running jmap -heap

2 replies [Last post]
kumsan76
Offline
Joined: 2007-06-12
Points: 0

HI,
While running the jmap -heap I'm getting the following error with java SE build build 1.6.0_02-b05. So I'm unable to run any of the tools. Please help me to troubleshoot this issue.

Attaching to process ID 24801, please wait...
Exception in thread "main" sun.jvm.hotspot.debugger.UnmappedAddressException
at sun.jvm.hotspot.debugger.PageCache.checkPage(PageCache.java:191)
at sun.jvm.hotspot.debugger.PageCache.getData(PageCache.java:46)
at sun.jvm.hotspot.debugger.DebuggerBase.readBytes(DebuggerBase.java:188)
at sun.jvm.hotspot.debugger.linux.LinuxDebuggerLocal.readCInteger(LinuxDebuggerLocal.java:453)
at sun.jvm.hotspot.debugger.linux.LinuxAddress.getCIntegerAt(LinuxAddress.java:52)
at sun.jvm.hotspot.HotSpotTypeDataBase.getLongValueFromProcess(HotSpotTypeDataBase.java:391)
at sun.jvm.hotspot.HotSpotTypeDataBase.readVMTypes(HotSpotTypeDataBase.java:85)
at sun.jvm.hotspot.HotSpotTypeDataBase.(HotSpotTypeDataBase.java:68)
at sun.jvm.hotspot.bugspot.BugSpotAgent.setupVM(BugSpotAgent.java:550)
at sun.jvm.hotspot.bugspot.BugSpotAgent.go(BugSpotAgent.java:476)
at sun.jvm.hotspot.bugspot.BugSpotAgent.attach(BugSpotAgent.java:314)
at sun.jvm.hotspot.tools.Tool.start(Tool.java:146)
at sun.jvm.hotspot.tools.JMap.main(JMap.java:126)

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
miceng
Offline
Joined: 2008-03-15
Points: 0

Did you ever find a solution to this? I am getting the same issue with build 1.5.0_11-b03 on Xubuntu.

miceng
Offline
Joined: 2008-03-15
Points: 0

Actually, just realized that I was using JDK 1.6. Switching to 1.5 solved the problem.