Skip to main content

please help!

1 reply [Last post]
noktanet
Offline
Joined: 2006-04-23

Hi,
I'm a new user for jMaki and I have Eclipse 3.0.1.1 and Websphere server 5.1 on IBM RAD. I downloaded the jMaki plug-in from the website version 0.9.7.2. But I have an error. (I know this- version 0.9.7.2 for eclipse 3.3)

[28.08.2007 12:06:09:059 EEST] 63232b42 WebGroup E SRVE0026E: [Servlet Error]-[File "http://jmaki/v1.0/jsp" not found]: org.apache.jasper.JasperException: File "http://jmaki/v1.0/jsp" not found.

It run successfully on eclipse 3.3. But I need the jMaki on eclipse 3.0.11(IBM RAD version).and I can't update this version to 3.3.
How can I do?
Which version of jMaki may I use?

Best regards.
Murat

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
gmurray71
Offline
Joined: 2003-07-31

Our current support with the plugin is for Eclipse 3.2 and 3.3.

What you are going to need to do is create an application using an ant task we provide in our release:

You can find it at:

https://ajax.dev.java.net/download.html

The jmaki-java-0.9.7.3.zip bundle has this task in the core directory. If you look at the sample applications in the samples directory you can see how to add widgets using ant. The other option is to add the widget libraries (found in the widgets directory) by unzipping it into the web app.

The application structure for jMaki may be found at:

https://ajax.dev.java.net/jmaki-app.html

We intend on improving the ant task and would welcome any suggestions. Once you get your application created you can then import it into Eclipse. For now this is the best we can offer.