Skip to main content

Strange 3DS model problem

1 reply [Last post]
psychoreggae
Offline
Joined: 2007-03-20

This is probably a 3DS Max problem rather than a programming problem - our artist says it's a programming problem, I say it's a modeling problem. :) I was hoping somebody had some experience with this problem and could confirm or reject it one way or the other.

OK, here's the situation. When our modeler looks at his model in Max, it looks fine. However when I load it into the scene (using StarFire 2.20), different sections of the model's geometry are scaled differently. For example, our model is a ship and when it's loaded into the scene, the ship's hull will be of proper scale, but the deck guns will be 20X the scale of the hull. It isn't just one section of geometry. Many sections are drastically out of scale with one another. But, again, it looks perfect in MAX.

Has anybody encountered a similar situation and either found a solution or at least identified the actual source of the problem?

Any insights would be greatly appreciated.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
psychoreggae
Offline
Joined: 2007-03-20

Hah! I was right! It wasn't a programming problem but a modeling problem! In case anybody else runs into this problem I'll go ahead and post the workaround...

Our artist had to take his model and export it as a 3ds. Then, re-import that same exported 3ds model again. And then finally export it *again* as a 3ds. After he did all that the resulting model scaled exactly the way it was supposed to in the application.

I don't know Max so I don't know why that worked but this did the trick for us. :)

Hope this helps...