Skip to main content

when cvm run ,it report Segmentation fault,Why?

1 reply [Last post]
esisiy
Offline
Joined: 2007-04-28
Points: 0

Hello,everyone,
I have builded the cvm successfully,but when I run it on target paltform, it report Segmentation fault, I don't know Why ? Who can tell me the reasons?

[root@fa cdc_bin]# ls
bin legal testclasses.zip
democlasses.jar lib

[root@fa cdc_bin]# cd bin
[root@fa bin]# ls
cvm
[root@fa bin]# cd ../lib
[root@fa lib]# ls
btclasses.zip security
content-types.properties zi

[root@fa lib]# cd ..
[root@fa cdc_bin]# bin/cvm -cp testclasses.zip HelloWorld
pc : [<40012324>] lr : [<4000e77c>] Not tainted
sp : bfffe674 ip : bfffe65c fp : bfffea90
r10: 40020198 r9 : 40157e58 r8 : 00000004
r7 : 4000ee5c r6 : 00000000 r5 : 00000000 r4 : bfffeae4
r3 : 4003c72c r2 : 4003f2e8 r1 : 00000000 r0 : 00000000
Flags: NzCv IRQs on FIQs on Mode USER_32 Segment user
Control: C000317F Table: 33CF4000 DAC: 00000015
Segmentation fault

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
xyzzy
Offline
Joined: 2006-08-30
Points: 0

> Hello,everyone,
> I have builded the cvm successfully,but when I
> run it on target paltform, it report Segmentation
> fault, I don't know Why ? Who can tell me the
> reasons?
>
> [root@fa cdc_bin]# ls
> [b]bin legal testclasses.zip
> democlasses.jar lib [/b]
> [root@fa cdc_bin]# cd bin
> [root@fa bin]# ls
> [b]cvm[/b]
> [root@fa bin]# cd ../lib
> [root@fa lib]# ls
> [b]btclasses.zip security
> content-types.properties zi[/b]
> [root@fa lib]# cd ..
> [root@fa cdc_bin]# bin/cvm -cp testclasses.zip
> HelloWorld
> [b]pc : [<40012324>] lr : [<4000e77c>] Not
> tainted
> sp : bfffe674 ip : bfffe65c fp : bfffea90
> r10: 40020198 r9 : 40157e58 r8 : 00000004
> r7 : 4000ee5c r6 : 00000000 r5 : 00000000 r4 :
> bfffeae4
> r3 : 4003c72c r2 : 4003f2e8 r1 : 00000000 r0 :
> 00000000
> Flags: NzCv IRQs on FIQs on Mode USER_32 Segment
> user
> Control: C000317F Table: 33CF4000 DAC: 00000015
> Segmentation fault[/b]

Can you provide a stack backtrace from gdb, using a debug build of cvm?

Dean