Skip to main content

CDC not building

5 replies [Last post]
rfr
Offline
Joined: 2005-04-15

HI,

Something about a week or two ago, I downloaded your SVN version from repository and it was compiling. Since the last time i update my version its not compiling anymore.

I'm catching an error at make in ".compile.btclasses" which is in file rules.mk.
Here is the output:
--
[exec] echo "Compiling build-time classes..."; \
[exec] javac -g:none -J-Xms32m -J-Xmx128m -encoding iso8859-1 -source 1.4 -target 1.4 \
[exec] -d ../../build/linux-x86-suse/./btclasses \
[exec] -bootclasspath ../../build/linux-x86-suse/./btclasses \
[exec] -classpath ../../build/linux-x86-suse/./btclasses \
[exec] -sourcepath \
[exec] @../../build/linux-x86-suse/./.btclasses.list ;\
[exec] fi
[exec] Compiling build-time classes...
[exec] javac: -sourcepath requires argument
[exec] Usage: javac
--

Can you help me?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Hinkmond Wong

Hi rfr,

Make sure you have both the cdc/trunk and tools/trunk at least at rev. 3434.

cd ..
svn update cdc
At revision 3434.
svn update tools
svn update tools
At revision 3434.

What is your exact build command? With rev. 3434, I can build
CDC/Foundation Profile using this command line:

cdc cdc/build/linux-x86-generic
make clean; make J2ME_CLASSLIB=foundation

...
cc ../../src/share/native/java/lang/fdlibm/src/w_remainder.c
cc ../../src/share/native/java/lang/fdlibm/src/w_sqrt.c
lib ../../build/linux-x86-generic/./obj/fdlibm.a
Linking ../../build/linux-x86-generic/./bin/cvm
Done Linking ../../build/linux-x86-generic/./bin/cvm

Also, what host platform are you using? Linux/x86? If so, which distro?

Hopefully we can help analyze this for you.

Hinkmond

phonemeadvanced@mobileandembedded.org wrote:
> I've downloaded the whole thing again, from zero, and nothing. I got the same error.
>
> I'm using:
> "svn checkout https://phoneme.dev.java.net/svn/phoneme/components/cdc/trunk cdc --username rfr"
>
> Thanks for your answer.
> [Message sent by forum member 'rfr' (rfr)]
>
> http://forums.java.net/jive/thread.jspa?messageID=208821
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: advanced-unsubscribe@phoneme.dev.java.net
> For additional commands, e-mail: advanced-help@phoneme.dev.java.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: advanced-unsubscribe@phoneme.dev.java.net
For additional commands, e-mail: advanced-help@phoneme.dev.java.net

rfr
Offline
Joined: 2005-04-15

IT WORKED.

Thanks EVERYONE, specially Hinkmond Wong. You openned my eyes that I wasn't sycronizing the tools project.

Thanks everyone again for the attention.

jianglizhou
Offline
Joined: 2006-10-16

This problem should have been fixed. Try updating your copy with the latest repository. Also try a clean build.

Jiangli Zhou

rfr
Offline
Joined: 2005-04-15

I've downloaded the whole thing again, from zero, and nothing. I got the same error.

I'm using:
"svn checkout https://phoneme.dev.java.net/svn/phoneme/components/cdc/trunk cdc --username rfr"

Thanks for your answer.

cjplummer
Offline
Joined: 2006-10-16

Please post your build command and build log.

thanks,

Chris