Skip to main content

Firefox 2.0.1 or greater lists Java 6 as incompatible add-on

1 reply [Last post]
teedee09
Offline
Joined: 2006-04-06

I have seen this on both Windows 2000 and XP, with both Java 6 and 6 update 1. I have worked around this by going to the
Firefox Install Dir\extensions\{CAFEEFAC-0016-0000-000[numberOfPlugin]-ABCDEFFEDCBA}\install.rdf
and manually bumping the max version to 2.*. This does resolve the issue for me on two machines I have tried it on and at least one coworker has had success with it. It looks like it would be easy to fix in the binary, if my understanding is correct, by going to /deploy/src/plugin/share/ffjavaconsole/install.rdf line #15
< 2.0
> 2.*
I thought I'd run that diff by here to see if anyone else was experiencing this, and since the Java 6 source must be tightly controlled at this point. Also, I don't know what the policy is as far as the highest release of Firefox Java wishes to claim compatibility with. If anyone could reply to confirm this behavior, let me know if I should submit a bug report, tell me who to email, or tell me if/how I should submit a fix, etc., that would be great. I did try querying the bug database, I did not see this posted, but I did not try every way one might describe the issue.
Thank You,
Tom

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
teedee09
Offline
Joined: 2006-04-06

This is already covered by bug #6506635. If someone is experiencing this and didn't want to create an xpi for the workaround, it might be useful to know that I have not had to create an xpi for the workaround to take effect, so long as I closed the browser and restarted it.
Tom