Skip to main content

Porting phoneME advanced to Nokia 770 / N800?

3 replies [Last post]
linuxhippy
Offline
Joined: 2004-01-07

Hi there,

I would like to port phoneME Advanced to my Nokia770, however some questions remain open and it would be great to get some answers:

* The Nokia770 has an ARM926EJ-Sid (some ARM9), the N800 a ARM11 as far as I know. Are these processors supported by the phoneME Advanced JIT?
* Are there "native" X11 peers or should I use the QT peers instead? Which version of QT do you recommend?
* Any hints / common pitfalls I should know about.

Thank you Sun for making this possible! I couldn't believe when I found that even CDC is opensourced as GPL. Wow :-)

lg Clemens

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
desperado
Offline
Joined: 2005-06-16

I think you need to check about software development on the 770/N800. I may be wrong but I thought the UI on that platform (known as hildon) is GTK based. I didn't think it used QT.

linuxhippy
Offline
Joined: 2004-01-07

Jippie, there is already a port with working JIT only missing AWT support. Seems I've overseen it.

Thank you Sun for open-sourceing java :-)

lg Clemens

gcruscoe
Offline
Joined: 2003-06-30

Can you post a link. I can't find any Java for the Nokia 770 and I want it soooo bad :-).

Thanks