Skip to main content

Combo box JSF

6 replies [Last post]
carlosangarita
Offline
Joined: 2006-07-07
Points: 0

Hi all
I´ve installed the jmaki java samples v.8 on my glassfish V2 b25 and tested the combo box component which I need in my app, but I have a problem showing the bean property into the combobox, what happens is that it simply don't load any value in the box, but looking at http://www.javaserver.org/jmaki/ I can see it working, so my question is, Has anyone make it work? and what version are you using?
Thanks in advance

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
gmurray71
Offline
Joined: 2003-07-31
Points: 0

I believe the version is v.7 which is getting dated. We release v8.1 a week ago though it's labeled on the site using .8. You can check the name of the file you downloaded or in the config.json file to find the version.

There was a change made that you might be running into.

The Dojo ComobBox has two attributes which you need to map properly

selected maps to the managed bean property to what is selected and value maps to the bean method that generates the list of what your are displaying.

This is working in the v.8.1 app as it is one of the first test cases I always check.

ndzpac
Offline
Joined: 2005-09-02
Points: 0

Hi,

I am also facing the same issue, I don't see values in combobox.

As per tutorial (http://blogs.sun.com/divas/entry/using_the_dojo_combobox_in) I found:

I have get data method i.e. completeCountry in ApplicationBean1 and get set method in AjaxTest bean.

So it looks that it has changed,

Just wondering what would be new syntax? I tried below mentioned code but didn't work:

Any suggestions?

Thanks.

gmurray71
Offline
Joined: 2003-07-31
Points: 0

So just to confirm you have JSF managed beans named AjaxTest and ApplicationBean1?

If the objects exist you should be able to use:

The values should be set when the component is rendered. If you look at your page source you would see the values rendered inline with the component creation.

I will test this out to make sure things are working alright.

What release of jMaki are you using by the way?

ndzpac
Offline
Joined: 2005-09-02
Points: 0

Thanks.

Both i.e. AjaxTest and ApplicationBean1 are managed bean, and using java studio creator.

Also looked in page source, I don't see values as well and tried to debug and it looks that completeCountry method in ApplicationBean1 never got called.

I am using latest version (sample zip v.8.1), just downloaded yesterday.

carlosangarita
Offline
Joined: 2006-07-07
Points: 0

Thank u guys it worked for me using the last version of both, glassfish V2 b30 and jmaki samples 8.1, and doing a test with my old glassfish V2 b25 it worked too, so the problem (at least the mine) was the jmaki version, Thank u very much

yoannlt
Offline
Joined: 2006-05-18
Points: 0

hi,
I'm download jmaki-v.8.3.1 for using combobox. All is good except that I don't know how can i set a default value.

Can you help me ?