Skip to main content

X-Applications don't start on Looking Glass ! Please Help ! !

4 replies [Last post]
fenix_nbk_
Offline
Joined: 2007-01-06
Points: 0

hi all !

Just downloaded Looking Glass v1.0, megapack.
I installed that under /home/user (should I install it system wide?)

My system: openSUSE 10.2, Linux x86, XGL disabled, GeForce 5200 with nVidia drivers (OpenGL 1.4), 1GB of RAM.

The X-applications don't start at all !

In "app" mode nothing happens, the system just ignores my mouse clicks and continues working, while in "dev" mode, they do start but in the host environment (read: in KDE).
I have tried 2: FireFox and xterm.

Please Help !

What info must I provide ?

BTW: I am noob in this project, but I know Linux and able to learn - This Project looks EXCELLENT ! Thanks Sun !

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
fenix_nbk_
Offline
Joined: 2007-01-06
Points: 0

OK, and after I find my fonts, what to do next?

How to configure Looking Glass (LG3D) to use them?

diabeteo
Offline
Joined: 2005-11-08
Points: 0

> Just downloaded Looking Glass v1.0, megapack.
> I installed that under /home/user (should I install
> it system wide?)

If you are using GDM it is better to install lg3d under "/usr/share/" because then you can add Looking Glass to the GDM session menu just by running "postinstall.sh" script that can be found in "/usr/share/lg3d/bin"

> The X-applications don't start at all !
>
> In "app" mode nothing happens, the system just
> ignores my mouse clicks and continues working, while
> in "dev" mode, they do start but in the host
> environment (read: in KDE).
> I have tried 2: FireFox and xterm.
>

I think that this is caused by the lack of some fonts (maybe lg3d does not know where to find them).

Please copy the errors from the console window.

As [i]deronj[/i] wrote in "[Linux] only lg3d-dev runs, solutions doesnt work, any idea?" topic:

> (...) Unfortunately, there is no
> standard location for the X11 font files in Linux and
> distros put them all over the place.

So first of all we must know where the X11 fonts & rgb.txt are stored in OpenSuSE.

As far as I remember in OpenSuSE 10.1 fonts are stored under "/usr/X11R6/lib/X11/fonts". I don't know where they are stored in 10.2 version.

Regards,

Stanley

billnot
Offline
Joined: 2007-01-08
Points: 0

I am using a very similar system to fenix_nkb - OpenSUSE 10,2, Nvidia Geforce 7900GS, 2Gb RAM. I installed Looking Glass into /usr/ share as advised in the documentation.

I can confirm that my system behaves identically to his - i.e. no launching of applications from app mode and launching in the normal desktop (KDE)in dev mode.

Fonts are kept in /usr/include/X11/fonts.

There are no error messages when I launch lg3d-dev from xterm.
Where does lg3d keep its logs - maybe if I look there something will come to light.

diabeteo
Offline
Joined: 2005-11-08
Points: 0

In [i]dev[/i] mode X apps always appear outside the LG window (it means in the X session from which you launched Looking Glass).

> Where does lg3d keep its logs - maybe if I look there
> something will come to light

Please see this section on the main page:
https://lg3d.dev.java.net/index.html#Reporting_Issues

I'm planning to install OpenSuSE later this month. By this time, I hope deronj will help you :)

Regards,

Stanley