Skip to main content

[Linux] only lg3d-dev runs, solutions doesnt work, any idea?

1 reply [Last post]
teique
Offline
Joined: 2006-12-30
Points: 0

Hi all, 1st time lg3d user here :)

I login into KDE then I cd to lg3d path and issue bin/lg3d-app,
and I get one of the 2 errors already reported at troubleshooting sessions:

"Fatal Server error: Cannot establish any listening sockets"
Then I remove both X0 and X1, run again and error still happens, any idea here?

Some other times, bin/lg3d-app brings up this other error:
"Fatal server error: could not open default font 'fixed'"
I try the "mv" solution but still doesnt work.
at the pointed path, I have these files:
libbitmap.la
libbitmap.so
libfreetype.la
libfreetype.so
libtype1.la
libtype1.so
I dont understand what files are missing, and cant find what files I should put there..., what files means the "fixed" font at all? any help here?

PS.: my sys is GoboLinux :)

Message was edited by: teique

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
deronj
Offline
Joined: 2003-09-02
Points: 0

lg3d-app starts up an Xvfb (headless X server) which has
been customized for LG. Unfortunately, there is no standard location for the X11 font files in Linux and distros put them all over the place. If you can find where the X11 fonts are stored in GoboLinux I can tell you how to modify lg3d-app to run on your system. Also, you need to find where the X11 color names file rgb.txt is stored.