Skip to main content

Kill Xgl !

3 replies [Last post]
Anonymous

Hi

Since saturday, we got 4 LG3D crash report. 3 of them are caused by people
running Xgl while they have a nVidia graphic card, meaning that they don't
need Xgl.
Looking Glass can't run in Xgl because of a Xgl limitation : Xgl uses Mesa for
the client, providing only GLX 1.2, while LG3D need GLX 1.3.
Can't we do something about it, like saying with an extremely big font on the
main web page : "Stop using the crappy Xgl when you don't need it" ?

Thanks
Pierre

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@lg3d.dev.java.net
For additional commands, e-mail: interest-help@lg3d.dev.java.net

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
alihelmy
Offline
Joined: 2006-03-28

> Looking Glass can't run in Xgl because of a Xgl
> limitation : Xgl uses Mesa for
> the client, providing only GLX 1.2, while LG3D need
> GLX 1.3

I have no problem with XGL, im only saying that, i have JUST downloaded and started trying LG3D today, so i was going to fix the opengl thing later, but up to now, ive got no problem at ALL with LG3D, although im running GLX1.2, not xgl, but still GLX1.2

[i]
seth@desktop:$ glxinfo | grep "GLX version"
GLX version: 1.2[/i]

Pierre D.

One more time ... (crash report 28)

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@lg3d.dev.java.net
For additional commands, e-mail: interest-help@lg3d.dev.java.net

scoobs_2005
Offline
Joined: 2006-08-26

Thanks for this information, this describes why I can not run LG3D on OpenSuse with Xgl.