Skip to main content

Build broken

2 replies [Last post]
ivelin
Offline
Joined: 2003-07-13

There were several check-ins yesterday, which were not coordinated very well. The build is now broken. Please fix it if you recognize the problem.

javacompile:
[javac] Compiling 282 source files to C:\work\Mobicents\classes
[javac] C:\work\Mobicents\src\org\mobicents\slee\resource\ResourceAdaptorEntity.java:36: package org.apache.commons.
jxpath.util does not exist
[javac] import org.apache.commons.jxpath.util.TypeUtils;
[javac] ^
[javac] C:\work\Mobicents\src\org\mobicents\slee\container\management\ResourceAdaptorDescriptorParser.java:28: packa
ge org.apache.commons.jxpath.util does not exist
[javac] import org.apache.commons.jxpath.util.TypeConverter;
[javac] ^
[javac] C:\work\Mobicents\src\org\mobicents\slee\container\management\ResourceAdaptorDescriptorParser.java:29: packa
ge org.apache.commons.jxpath.util does not exist
[javac] import org.apache.commons.jxpath.util.TypeUtils;
[javac] ^
[javac] C:\work\Mobicents\src\org\mobicents\slee\resource\ResourceAdaptorEntity.java:315: cannot find symbol
[javac] symbol : variable TypeUtils
[javac] location: class org.mobicents.slee.resource.ResourceAdaptorEntity
[javac] value = TypeUtils.convert(lexicalValue, clazz);
[javac] ^
[javac] C:\work\Mobicents\src\org\mobicents\slee\container\management\ResourceAdaptorDescriptorParser.java:247: cann
ot find symbol
[javac] symbol : variable TypeUtils
[javac] location: class org.mobicents.slee.container.management.ResourceAdaptorDescriptorParser
[javac] Object value = TypeUtils.convert(lexicalValue, clazz);
[javac] ^
[javac] Note: Some input files use or override a deprecated API.
[javac] Note: Recompile with -Xlint:deprecation for details.
[javac] 5 errors

BUILD FAILED
C:\work\Mobicents\build.xml:154: Compile failed; see the compiler error output for details.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
kulikoff
Offline
Joined: 2005-11-30

There was an error on my side. Seems Stefano already fix this problem: add commons-jxpath-1.1.jar to project.classpath

ivelin
Offline
Joined: 2003-07-13

Build is fine again. Thanks to kulikoff and stezak.
We are back on track for cr2 release. Only a couple of tests left to fix.